lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-14-2018, 08:49 AM   #11
Gone Wild
 
mgray70's Avatar
E-Z-GO
 
Join Date: Apr 2013
Location: Deep Run, NC
Posts: 1,370
Default Re: No power

Quote:
Originally Posted by pingzing View Post
Goldsboro about 3 1/2 away from kannapolis
Email is the best way to get up with Scotty. It's on his site. You have no shortage of golf cart shops in Goldsboro! Lol I'm located 30 minutes east of you.

Sent from my SM-G930R4 using Tapatalk
mgray70 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-16-2018, 11:25 AM   #12
Not Yet Wild
 
Join Date: Oct 2015
Location: nc
Posts: 59
Default Re: No power

Bump
pingzing is offline   Reply With Quote
Unread 02-16-2018, 11:26 AM   #13
Not Yet Wild
 
Join Date: Oct 2015
Location: nc
Posts: 59
Default Re: No power

Quote:
Originally Posted by mgray70 View Post
Email is the best way to get up with Scotty. It's on his site. You have no shortage of golf cart shops in Goldsboro! Lol I'm located 30 minutes east of you.

Sent from my SM-G930R4 using Tapatalk
we do have several around I was trying to do it myself but I may have to take it in.
pingzing is offline   Reply With Quote
Unread 02-16-2018, 02:35 PM   #14
Gone Wild
E-Z-GO
 
Join Date: Sep 2016
Location: Northern California
Posts: 632
Default Re: No power

Ping, make a new post in this thread summarizing where youíre at and what you know so far. Ie: cart type, drive system, pack voltage, reiterate your problem, etc. youíll get the help you need here. Scotty is very helpful on this site and gives excellent customer service through email. However, I donít know that he answers individual questions through email. And, there are many others on this board that can, and will, help you.

Unfortunately Iím not that guy. I donít have a pds, so donít pay as much attention, but Iím sure there is a diagnostic flow chart for your cart on this forum. Check the stickies above and/or try the search feature. Hang in there , youíll get the help you need right here.
orangeman6 is offline   Reply With Quote
Unread 02-16-2018, 07:01 PM   #15
Gone Wild
 
mgray70's Avatar
E-Z-GO
 
Join Date: Apr 2013
Location: Deep Run, NC
Posts: 1,370
Default Re: No power

I have trouble telling sometime how to check something in detail, but I would check the solenoid to make sure it was closing. Just because it clicks doesn't mean it makes contact. Check the throttle signal on the white and black wires on the j4 terminal. I think there is a sticky that explains how to check throttle signal. I was working on a PDS last weekend with the same symptoms. It turned out to be the motor brushes were stuck because the cart had been flooded up to the motor at some point, and once the brushes lost contact with the armature it stopped. Once I freed them up it went back to work. Check the stickies for diagnostic info and I think it has step by step info that is explained better than I can explain it.

Sent from my SM-G930R4 using Tapatalk
mgray70 is offline   Reply With Quote
Unread 02-16-2018, 07:09 PM   #16
Gone Wild
 
mgray70's Avatar
E-Z-GO
 
Join Date: Apr 2013
Location: Deep Run, NC
Posts: 1,370
Default Re: No power

Also, put the cart in diagnostic mode and see what code you get. You do that by switching from neural to reverse five times, then listen for the beeps when you press the go pedal. The beep codes are explained on the controller cover by the tow run switch.

Sent from my SM-G930R4 using Tapatalk
mgray70 is offline   Reply With Quote
Unread 03-14-2018, 09:07 AM   #17
Not Yet Wild
 
Join Date: Oct 2015
Location: nc
Posts: 59
Default Re: No power

after months of trying to figure this out I finally broke down and took it to the dealer it ended up being the controller box having a intermittent fault all is well now thanks everyone who took time to answer some questions
pingzing is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G1 not starting...no power power coming from magneto? Gas Yamaha
Full power in reverse, part power in forward Electric EZGO
Ezgo dies under power then regains power Electric EZGO
2005 Precedent starts of powered, then loses power, reverse always power Electric Club Car
Power Wise Charger worked after board replaced now back to no power Electric EZGO


All times are GMT -5. The time now is 02:50 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.