lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-26-2018, 02:19 PM   #1
Not Yet Wild
 
Join Date: Aug 2017
Posts: 22
Default 2014 EZGO Txt WONT MOVE!!

Hey everyone! Im having an issue with a 2014 EZGO txt 48V with Curtis controller. I have seem to try everything under the sun with no luck. The cart has no response whatsoever. No back up buzzer, no solenoid clicking, nothing. List of things Ive tried.
-Pack Voltage 49.7V
-Voltage at Battery side of solenoid-49.7V
-Voltage at controller side of solenoid-49.2V (resistor is good)
-Continuity at Key switch,F&R switch, and TOW/RUN switch all good.
-Put in a new solenoid, still nothing,
-Traced all wires no burnt contacts or corroded wire.
-49.7 Volts at the red micro switch wire under the floorboard
-Continuity at microswitch under the floor is good
-once micro switch is released I get 49.7V coming out the other side
-When i flip the switch from Tow to Run i get one short "beep"

Im starting to think it may be the ITS, has anyone ran into this issue before and have any ideas or tests to try?

Much appreciated!
kcc865 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-26-2018, 08:52 PM   #2
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 13,353
Default Re: 2014 EZGO Txt WONT MOVE!!

We don't sell many of the newer Txt-48, but I'm not so sure there's supposed to be a resistor on there. Try removing it, won't harm anything.
cgtech is offline   Reply With Quote
Unread 03-27-2018, 10:45 AM   #3
Not Yet Wild
 
Join Date: Aug 2017
Posts: 22
Default Re: 2014 EZGO Txt WONT MOVE!!

They are suppose to have one on there, according to the wiring diagram. Tried removing it and still no luck.
kcc865 is offline   Reply With Quote
Unread 03-27-2018, 12:15 PM   #4
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 15,448
Default Re: 2014 EZGO Txt WONT MOVE!!

The charger port might be bad.

Check of battery pack voltage on blue wire coming out of charger port, or on Pin-5 at controller.
JohnnieB is offline   Reply With Quote
Unread 03-27-2018, 12:26 PM   #5
Gone Wild
 
kernal's Avatar
E-Z-GO
 
Join Date: Jul 2010
Location: Peachtree City, Ga.
Posts: 2,040
Default Re: 2014 EZGO Txt WONT MOVE!!

Quote:
Originally Posted by JohnnieB View Post
The charger port might be bad.

Check of battery pack voltage on blue wire coming out of charger port, or on Pin-5 at controller.
What JohnnieB said. Local cart shop that specializes in RXV reports this as a problem on RXV's some times. I think newer TXT's use the same charge port.
kernal is offline   Reply With Quote
Unread 03-27-2018, 01:28 PM   #6
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 15,448
Default Re: 2014 EZGO Txt WONT MOVE!!

Quote:
Originally Posted by kernal View Post
What JohnnieB said. Local cart shop that specializes in RXV reports this as a problem on RXV's some times. I think newer TXT's use the same charge port.
From what I understand, the charger port is charger specific rather than cart specific. If the cart comes with a 48V Delta-Q charger, that is the charger port it has.

It has the electronic equivalent of the infamous reed switch. If the blue wire is dead when the charger isn't connected, connect the blue wire to B+ and you are good to go. Of course, cart will not be disabled when charger is plugged into port, so loop charger cable through steering wheel to remind people not to drive off when the charger is connected.
JohnnieB is offline   Reply With Quote
Unread 03-28-2018, 08:06 AM   #7
Not Yet Wild
 
Join Date: Aug 2017
Posts: 22
Default Re: 2014 EZGO Txt WONT MOVE!!

I wish I would have remembered to look at this thread again. It was determined to be the charging port. The black box on the end of the grey wire was bad and causing the cart not to run. I want to pull my hair out now.... itís always something so simple.


Sent from my iPhone using Tapatalk
kcc865 is offline   Reply With Quote
Reply

Tags
2014, curtis, ezgo, solenoid, txt
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2014 EZGO RXV will not move Electric EZGO
EZGO wont move Electric EZGO
Ezgo dcs solenoid clicks but wont disengage and wont move Electric EZGO
93 ezgo wont move Electric EZGO


All times are GMT -5. The time now is 03:53 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.