lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-24-2018, 06:40 PM   #21
Gone Wild
E-Z-GO
 
Join Date: Sep 2016
Location: Northern California
Posts: 1,109
Default Re: Connected Alltrax to laptop, now error codes

Didnít I read somewhere that if youíre not careful you can damage the controller when you access that port to plug in your laptop? Or was that on older versions? Or am I just making up random crap? Hopefully the controller is ok, but I could have sworn Iíve read that somewhere on this site.
orangeman6 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-24-2018, 06:47 PM   #22
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 13,980
Default Re: Connected Alltrax to laptop, now error codes

If you touch anything live anywhere (potentially even the cart frame) to the end of the USB cord, the controller will be destroyed.
cgtech is offline   Reply With Quote
Unread 05-24-2018, 09:17 PM   #23
Getting Wild
E-Z-GO
 
Join Date: Jun 2017
Location: New Strawn, KS
Posts: 120
Default Re: Connected Alltrax to laptop, now error codes

Quote:
Originally Posted by cgtech View Post
If you touch anything live anywhere (potentially even the cart frame) to the end of the USB cord, the controller will be destroyed.
Well then it is probably destroyed. Never would have thought to have been cautious with the USB cord.
VanillaXtract is offline   Reply With Quote
Unread 06-05-2018, 06:36 AM   #24
Getting Wild
E-Z-GO
 
Join Date: Jun 2017
Location: New Strawn, KS
Posts: 120
Default Re: Connected Alltrax to laptop, now error codes

Talked to Alltrax yesterday. They said their initial tests show the controller is operating fine. They are going to hook it up to their ITS since I had low voltage readings with no sensor connected. In the meantime, is there anything I can check on the cart that might cause the controller to output low voltage to the throttle?
VanillaXtract is offline   Reply With Quote
Unread 06-05-2018, 11:30 AM   #25
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 15,801
Default Re: Connected Alltrax to laptop, now error codes

The symptom is: Low voltage (7.5V) between C4 Pins 3 & 4 at controller with C4 cable disconnected from the XCT controller.

Since the voltage between C4 Pins 3 & 4 is supposed to be 10V with pedal up and 6V with pedal down, the voltage between those two pins ought to be 10V or higher with C4 disconnected. Other than the ITS power supply in the XCT being defective, the input voltage to it may be low, so check the voltage input path(s).

Excluding the high current circuitry, there are two battery pack voltage inputs, one feeding the external switches and solenoid coil, the other feeding the internal power supplies for the XCT's electronics and ITS. I'm not 100% sure which is which, so check them both out.

C1 Pin 4 is fed by a wire from the reed switch. (Battery pack voltage unless charger is connected)
C1 Pin-5 is fed by a wire from the solenoid's battery side large terminal. (Battery pack voltage 100% of the time)

Disconnect the battery pack negative lead so there isn't any voltage on the stuff connected to the positive side.

Using an Ohmmeter, measure the resistance between C1 Pin-4 and the main positive terminal of battery pack. Should be close to 0Ω.

Using an Ohmmeter, measure the resistance between C1 Pin-5 and the main positive terminal of battery pack. Should be close to 0Ω.

These two voltages also have to go through the Run/Tow switch, so Ohm that out too.

With Run/Tow in Run, measure the resistance between C3 Pins 1 & 2 and between C3 Pins 3 & 4. Both should be close to 0Ω.

--------
When the XCT is returned, if it still doesn't work, look at the voltages on C1 Pins 4 & 5 as well as the voltages on all four on the C3 pins.
Attached Images
File Type: jpg XCT-PDS with regen diode -2.jpg (233.3 KB, 0 views)

Last edited by JohnnieB; 06-05-2018 at 11:34 AM.. Reason: added stuff
JohnnieB is offline   Reply With Quote
Unread 06-05-2018, 11:38 AM   #26
Getting Wild
E-Z-GO
 
Join Date: Jun 2017
Location: New Strawn, KS
Posts: 120
Default Re: Connected Alltrax to laptop, now error codes

Quote:
Originally Posted by JohnnieB View Post
The symptom is: Low voltage (7.5V) between C4 Pins 3 & 4 at controller with C4 cable disconnected from the XCT controller.

Since the voltage between C4 Pins 3 & 4 is supposed to be 10V with pedal up and 6V with pedal down, the voltage between those two pins ought to be 10V or higher with C4 disconnected. Other than the ITS power supply in the XCT being defective, the input voltage to it may be low, so check the voltage input path(s).

Excluding the high current circuitry, there are two battery pack voltage inputs, one feeding the external switches and solenoid coil, the other feeding the internal power supplies for the XCT's electronics and ITS. I'm not 100% sure which is which, so check them both out.

C1 Pin 4 is fed by a wire from the reed switch. (Battery pack voltage unless charger is connected)
C1 Pin-5 is fed by a wire from the solenoid's battery side large terminal. (Battery pack voltage 100% of the time)

Disconnect the battery pack negative lead so there isn't any voltage on the stuff connected to the positive side.

Using an Ohmmeter, measure the resistance between C1 Pin-4 and the main positive terminal of battery pack. Should be close to 0Ω.

Using an Ohmmeter, measure the resistance between C1 Pin-5 and the main positive terminal of battery pack. Should be close to 0Ω.

These two voltages also have to go through the Run/Tow switch, so Ohm that out too.

With Run/Tow in Run, measure the resistance between C3 Pins 1 & 2 and between C3 Pins 3 & 4. Both should be close to 0Ω.

--------
When the XCT is returned, if it still doesn't work, look at the voltages on C1 Pins 4 & 5 as well as the voltages on all four on the C3 pins.
Does voltage matter on C1 Pin 4? When I was wiring my new charger in, I broke the reed switch. I put a female spade connector on the wire and placed it on my 12V fuse block.
VanillaXtract is offline   Reply With Quote
Unread 06-05-2018, 11:57 AM   #27
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 15,801
Default Re: Connected Alltrax to laptop, now error codes

Quote:
Originally Posted by VanillaXtract View Post
Does voltage matter on C1 Pin 4? When I was wiring my new charger in, I broke the reed switch. I put a female spade connector on the wire and placed it on my 12V fuse block.
EUREKA!!!!!!!!!! You found the problem!!!!!!!

C1 Pin-4 connects the the main positive terminal of the battery pack via the reed switch and the white charging cable. Move the wire now connected to the 12V fuse block to somewhere the has FULL battery pack voltage and you ought to be good to go when the XCT returns.
JohnnieB is offline   Reply With Quote
Unread 06-05-2018, 01:26 PM   #28
Getting Wild
E-Z-GO
 
Join Date: Jun 2017
Location: New Strawn, KS
Posts: 120
Default Re: Connected Alltrax to laptop, now error codes

Quote:
Originally Posted by JohnnieB View Post
EUREKA!!!!!!!!!! You found the problem!!!!!!!

C1 Pin-4 connects the the main positive terminal of the battery pack via the reed switch and the white charging cable. Move the wire now connected to the 12V fuse block to somewhere the has FULL battery pack voltage and you ought to be good to go when the XCT returns.
DOH!

Wish I would have thought of that prior to shipping it off.

Thank you so very much for sticking with my thread and helping me through all of this.
VanillaXtract is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Alltrax xct 400 pds blink codes Electric EZGO
RXV reverse switch malfunctions? I have error codes Electric EZGO
600 amp alltrax error codes Electric EZGO
Alltrax SPM no error codes but not working Extreme DC!
OBC Error codes Electric Club Car


All times are GMT -5. The time now is 02:22 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.