lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-21-2018, 02:59 PM   #1
Not Yet Wild
 
Join Date: May 2018
Posts: 2
Default Does not go forward or reverse when pressing the pedal

Equipped with a 48v conversion. When you press the pedal it does not go forward or reverse. I replaced the micro switch as recommended and that worked for about 30 minutes. When you switch from F-N-R your hear the click. Batteries are currently showing 53.2v on the meter.

I do not run it in water or use it on the beach.

Do you have any suggestions?

Planning on replacing the micro switch again to see if thatís it. If it is, what could be fouling the micro switch?
Havinfun is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-21-2018, 11:28 PM   #2
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 13,807
Default Re: Does not go forward or reverse when pressing the pedal

Have diode on solenoid? using good quality microswitch?
cgtech is online now   Reply With Quote
Unread 05-30-2018, 06:40 PM   #3
Not Yet Wild
 
Join Date: May 2018
Posts: 2
Default Re: Does not go forward or reverse when pressing the pedal

Quote:
Originally Posted by cgtech View Post
Have diode on solenoid? using good quality microswitch?
I believe it may have one or possibly two diodes on the solenoid if it looks like a small jumper wire. I would hope the switch is a quality one as I purchased it from a local golf cart dealer. I went by there yesterday and they told me to check this and that and after about the tenth trouble shooting recommendation it was clear as mud. One thing he did say was to check and see if anything may have overheated. I do not see any discoloration. The travel on the micro switch is in the correct position.

I ended up bringing the cart home to try and get it going again. I keep it at the lake which is about 3 hours away.
Havinfun is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
no forward/reverse when gas pedal pushed Gas EZGO
Ecellerator pedal-- lurches CC forward-reverse Electric Club Car
pressing gas pedal several times Electric EZGO
Doesnt Respond to Pedal (Forward or Reverse) Electric EZGO
87 elec CC goes without pressing pedal Electric Club Car


All times are GMT -5. The time now is 03:08 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.