lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-30-2018, 11:29 AM   #1
Not Yet Wild
 
Join Date: May 2018
Posts: 5
Default 1999 txt wonít move!

Iím new here and you guys have been a wealth of information just from reading through thread from people having a similar problem. If this is in the wrong place, just let me know!

Hereís my issue. I just purchased my first used cart about a month ago and put batteries in it the day I got it. Up until last weekend, everything was working perfectly... and then it didnít. The just stopped in the middle of a fairway. Long story short, I had the guys at the course tow it back to the club house and I came and loaded it up and took it to my shop. (Iím an automotive mechanic by day). Iíve checked everything I know to check going off of other posts here and Iím down to replacing the ITS throttle sensor. I talked to a local cart technician and he said that in 20 years of working on them, heís never actually had to replace one, so now Iím hesitant.

I have 6.3 volts from each battery. 37.96 volts from the battery pack. The solenoid clicks when the pedal is depressed. I checked voltage from the B- terminal on the Curtis controller to the white pin on the connector and have almost no voltage change from pedal up to pedal all the way down. The guy I talked to said I just need to replace the controller, but after 6 hours going through other peoples threads on this forum, I think it could be the throttle sensor.

Is there anything else I can check to be certain? I have a sensor coming from amazon, but I donít want to waste the money if itís going to turn out to be the controller. If I have to replace the sensor just to rule it out, then I guess Iím just out 30$ and thatís fine, but id like to avoid that if possible.

What do yíall think? You guys seem way more knowledgeable than the guy just trying to sell me a controller.


Sent from my iPhone using Tapatalk
Squiddlestix is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-30-2018, 11:41 AM   #2
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,758
Default Re: 1999 txt wonít move!

The controller supplies the ITS voltage. The ITS will malfunction when wet.
See troubleshooting at the top of this section in STICKIES
scottyb is offline   Reply With Quote
Unread 05-30-2018, 11:58 AM   #3
Getting Wild
E-Z-GO
 
Join Date: Jun 2017
Location: New Strawn, KS
Posts: 120
Default Re: 1999 txt wonít move!

Having gone through this very recently, make sure you check the ITS voltage at the sensor, at the controller, and at the controller with the sensor disconnected. That will let you know if it is the sensor or the controller. Is it a stock controller?

Here is my thread with a similar issue with lots of good advice and troubleshooting tips.

FYI: I wasted $30 on a sensor. I will ship my old one to you for shipping cost if you want one to try out.
VanillaXtract is offline   Reply With Quote
Unread 05-30-2018, 12:04 PM   #4
Gone Wild
 
Dixie Chopper's Avatar
E-Z-GO
 
Join Date: Jul 2017
Location: Baton Rouge
Posts: 347
Default Re: 1999 txt wonít move!

I'm not an expert by any stretch but one thing to check is the solenoid. Use a meter and check voltage on each side of the solenoid after it clicks. I had a bad solenoid that was clicking like normal but when I pressed the accelerator the voltage under load was dropping out to the low 20's on the controller side. It turned out the coil in the solenoid was bad
Dixie Chopper is offline   Reply With Quote
Unread 05-30-2018, 12:21 PM   #5
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: 1999 txt wonít move!

My stock '98 solenoid started melting at the inner contacts, due to years of abuse. It wasn't designed for what I was asking it to do. It worked sometimes, but became intermittent.

I also had an intermittent problem with the Molex connector between the throttle box and the wiring harness. Usually I could just unplug it, spray contact cleaner in it, and repeatedly plug/unplug/plug and it would work for months. I finally got tired of it, and cut off the connectors and soldered and heat-shrinked them.
Attached Images
File Type: jpg before.jpg (59.9 KB, 0 views)
yurtle is offline   Reply With Quote
Unread 05-30-2018, 12:33 PM   #6
Not Yet Wild
 
Join Date: May 2018
Posts: 5
Default Re: 1999 txt wonít move!

Sorry guys, I forgot to mention that the cart has a brand new solenoid. The guy I bought it from had an extra (still in the factory wrapper). I put it in when all this started and no dice. Iíve been going through the stickied troubleshooting thread and trying to rule out issues. Now that Iím a member, I have access to more info so Iíll try some more tests and let yíall know what I find.


Sent from my iPhone using Tapatalk
Squiddlestix is offline   Reply With Quote
Unread 05-30-2018, 12:43 PM   #7
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: 1999 txt wonít move!

Did you try the Molex connector, as I suggested?
yurtle is offline   Reply With Quote
Unread 05-30-2018, 01:21 PM   #8
Not Yet Wild
 
Join Date: May 2018
Posts: 5
Default Re: 1999 txt wonít move!

Quote:
Originally Posted by yurtle View Post
Did you try the Molex connector, as I suggested?


Yeah, I checked the connector. Oddly enough, I put each lead from my multimeter on each side of the throttle switch just to see what kind of reading I got, and when set to volts, I get nothing, but when set to ohms, the cart jumps to full speed when the pedal is pressed even a little. Iím assuming that would mean the throttle switch needs to be replaced, correct?


Sent from my iPhone using Tapatalk
Squiddlestix is offline   Reply With Quote
Unread 05-30-2018, 01:37 PM   #9
Not Yet Wild
 
Join Date: May 2018
Posts: 5
Default Re: 1999 txt wonít move!

Ok, Iím at a loss. It would do absolutely nothing twenty minutes ago and now after screwing around with the throttle sensor, it works flawlessly. I guess Iím going to replace the sensor and see what happens. Iím assuming that just having the sensor out and jostling around the wiring has (at least temporarily) fixed it. Iíll put new spade connectors on the wires at the sensor and replace the sensor itself in hopes that it will mitigate any future problems...


Sent from my iPhone using Tapatalk
Squiddlestix is offline   Reply With Quote
Unread 05-30-2018, 01:51 PM   #10
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: 1999 txt wonít move!

Are you calling the ITS the "sensor"? If so, I'd suspect the wiring before replacing a costly part. Others can chime in, but I've never heard of one failing intermittently. Getting them wet has caused problems, but drying them out usually cures that.
yurtle is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1999 Club Car DS won't move Electric Club Car
1999 48V DS will not move Electric Club Car
1999 ez go txt wont move Electric EZGO
1999 DS Cart won't move Electric Club Car
1999 Club Car will not move. Electric Club Car


All times are GMT -5. The time now is 02:19 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.