lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 03-26-2009, 04:58 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2009
Location: NorthEast Kansas
Posts: 10
Default Charger Question

I have a queston about my charger. Is it normal for the charger to continue to hum when it is finished charging, or am I diconnecting it too soon? The amp meter shows zero and it has been charging for about 12 hours.

Is this normal?

The charger is an automatic Lestronic II.
PHINMAN is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 03-27-2009, 05:59 AM   #2
Gone Wild
 
rusty1's Avatar
E-Z-GO
 
Join Date: Mar 2009
Location: cochran georgia
Posts: 299
Default Re: Charger Question

sounds like the auto cutoff may be bad how old are your batteries
rusty1 is offline   Reply With Quote
Unread 03-27-2009, 08:51 AM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2009
Location: NorthEast Kansas
Posts: 10
Default Re: Charger Question

"sounds like the auto cutoff may be bad how old are your batteries"

The batteries are a couple of years old. Is there some way to check the auto cutoff without the batteries? Can an auto cutoff be replaced?
PHINMAN is offline   Reply With Quote
Unread 03-27-2009, 11:19 AM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2009
Location: NorthEast Kansas
Posts: 10
Default Re: Charger Question

I spoke with a tech from lester electrical and he believes it is a relay switch that has gone bad. He also said it could be the logic board also, but believes the relay is the most likely cause. I will test over the weekend and post the results.

Thanks for the help!!
PHINMAN is offline   Reply With Quote
Unread 04-01-2009, 01:42 PM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Feb 2009
Location: NorthEast Kansas
Posts: 10
Default Re: Charger Question

It was the relay switch. Thanks for the help!
PHINMAN is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charger question Electric EZGO
charger question Electric Club Car
Charger question Electric Yamaha
charger question? Electric Yamaha
charger question Electric Club Car


All times are GMT -5. The time now is 07:54 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.