lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-03-2018, 06:16 PM   #1
Not Yet Wild
 
Join Date: Feb 2016
Posts: 12
Default 1994.5 EZGO Medalist ITS

Hey all, hereís a short rundown...bought a 1994.5 medalist that was already lifted. Put a high torque motor on it (+40% over stock) and replaced all high amp wires...runs great but doesnít seem to have much torque at all. Slows down to 5mph or less going up a hill. Tried troubleshooting everything I can think of including installing a hd solenoid (old one seemed to be getting excessively hot) but no increase in performance. Controller is a Curtis 1205-117. Today I decided to check the ITS...everything looks clean and dry and I got voltages 1.53 when solenoid engages gradually climbing to 2.73 full throttle. I saw on your ScottyBís throttle check thread that for a series with a Curtis controller it should be significantly lower than that. Is that correct? Everything seems to function fine (except for lack of torque) so if the ITS was that far out of specs would it account for that? I really appreciate any input.

Bryce
bkoether is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-03-2018, 06:17 PM   #2
Gone Wild
 
LukeL's Avatar
Yamaha
 
Join Date: Jun 2017
Location: Savannah, GA
Posts: 4,938
Default Re: 1994.5 EZGO Medalist ITS

My first guess would be the comptroller. Thatís not a very high amperage controller, is it? It will say on the end.


Club Car DS driverís club #59
LukeL is offline   Reply With Quote
Unread 11-03-2018, 07:04 PM   #3
Not Yet Wild
 
Join Date: Feb 2016
Posts: 12
Default Re: 1994.5 EZGO Medalist ITS

Think it’s 400 but not positive, markings are pretty rubbed off...I’m mainly trying to figure out if the ITS readings are normal for this cart. I’m not sure what the symptoms would be of wrong voltages from the ITS.
bkoether is offline   Reply With Quote
Unread 11-03-2018, 07:07 PM   #4
Gone Wild
 
LukeL's Avatar
Yamaha
 
Join Date: Jun 2017
Location: Savannah, GA
Posts: 4,938
Default Re: 1994.5 EZGO Medalist ITS

The biggest symptom would be slow speed and the throttle would be uneven. If it accelerates evenly and has normal speed, I would doubt the ITS is a problem.


Club Car DS driverís club #59
LukeL is offline   Reply With Quote
Unread 11-03-2018, 07:54 PM   #5
Not Yet Wild
 
Join Date: Feb 2016
Posts: 12
Default Re: 1994.5 EZGO Medalist ITS

I guess I don’t know what normal speed should be for this setup, but it does seem under powered. Throttle is smooth, just doesn’t seem to be a lot there.
bkoether is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
ezgo, 1994.5; medalist Electric EZGO
1994 EZGO Medalist Electric EZGO
1994 EZGO Medalist Electric EZGO
1994 Ezgo Medalist Electric EZGO
1994 36v ezgo medalist no go Electric EZGO


All times are GMT -5. The time now is 12:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2020, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.