lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-15-2019, 07:37 PM   #1
Not Yet Wild
 
Join Date: Feb 2019
Posts: 5
Default 2013 Bad Boy Buggy locks up after short use

I have a 2013 BadBoy Buggy Recoil iS. I just bought it and had trouble instantly. After i use it for about 20-30 mins (at most) the front end sounds like its kicking in and out making a noise and it "locks up" for lack of a better word. It bogs down where the front tires barely move and it wants to drag the back tires. Battery level shows fully charged but when it gets in this mode is starts draining the battery quickly.

I always leave it for about an hour or so with the key off and when I come back it will run perfectly fine for another 20 mins but has trouble climbing hills, etc like the batteries are dead. It always seems to do this when its mud/wet/or use of 20 mins or more.

Textron said that it sounds like batteries are bad and they aren't powerful enough to engage something in the cart thats why it starts doing that....(The technicians best guess by hows it acting).

Has anyone experienced this? Its the 72Volt model all electric so once it bogs down I'm stranded. Any suggestions would be great!! Please Help
jlawwell is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-20-2019, 11:52 AM   #2
Gone Wild
 
FF Titus's Avatar
 
Join Date: Jul 2011
Location: Rhode Island
Posts: 462
Default Re: 2013 Bad Boy Buggy locks up after short use

Yup, common problem. Start with the speed sensor on the front motor, same as an RXV speed sensor, 2013s also had the parasitic draw off the harness, so be sure to either find the correct OEM bypass, or flip the run tow switch when you're done with it, or less those controllers will draw 2Volts per day and after a week, you'll need a boost charger.

I'm also seeing people buying cheap batteries for these machines in order to get them running, yet wondering why they are only getting 30 minutes of ride time, not saying this is you, but do you have original batteries or new? If new, what are they?

But start with your speed sensor, I have them if you need one, Good luck! They are fun machines when running correctly. Ever flip the F to R on ice going full speed? ;)
FF Titus is offline   Reply With Quote
Unread 02-20-2019, 12:07 PM   #3
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: 2013 Bad Boy Buggy locks up after short use

I can't help but "hear" the guy driving in your avatar when I read your posts.
yurtle is offline   Reply With Quote
Unread 02-25-2019, 09:50 PM   #4
Not Yet Wild
 
Join Date: Feb 2019
Posts: 5
Default Re: 2013 Bad Boy Buggy locks up after short use

Quote:
Originally Posted by FF Titus View Post
Yup, common problem. Start with the speed sensor on the front motor, same as an RXV speed sensor, 2013s also had the parasitic draw off the harness, so be sure to either find the correct OEM bypass, or flip the run tow switch when you're done with it, or less those controllers will draw 2Volts per day and after a week, you'll need a boost charger.

I'm also seeing people buying cheap batteries for these machines in order to get them running, yet wondering why they are only getting 30 minutes of ride time, not saying this is you, but do you have original batteries or new? If new, what are they?

But start with your speed sensor, I have them if you need one, Good luck! They are fun machines when running correctly. Ever flip the F to R on ice going full speed? ;)
FFTitus----- Will you text me to help me figure out the issue? 937-402-6158 Thanks
jlawwell is offline   Reply With Quote
Unread 02-26-2019, 01:02 PM   #5
Not Yet Wild
 
Join Date: Feb 2019
Posts: 5
Default Re: 2013 Bad Boy Buggy locks up after short use

This was my first time using this site. not sure how to contact you but id like to buy a speed sensor and get your input on my buggy. call or text937-402-6158
jlawwell is offline   Reply With Quote
Unread 03-01-2019, 02:59 PM   #6
Gone Wild
 
FF Titus's Avatar
 
Join Date: Jul 2011
Location: Rhode Island
Posts: 462
Default Re: 2013 Bad Boy Buggy locks up after short use

Ryan, let you a message
FF Titus is offline   Reply With Quote
Reply

Tags
bad boy buggy
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
BAD BOY BUGGY 2013 Recoil IS Electric EZGO
2013 EZGO RXV Stall/Locks Up under Heavy Load Electric EZGO
locks up in Reverse Melex
replace glove box locks? Electric EZGO
steering locks to the right Gas Club Car


All times are GMT -5. The time now is 02:45 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.