lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-09-2019, 11:42 AM   #11
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: Ez Go Marathon Not Working

I misread your post and thought you only got readings in F, not R, thus my comments above. I'm not familiar with pot boxes, but would have thought it should work in F and R, however "somehow", the pot box "changes" from 0-5000 to half that in reverse. Dunno how. You can probably download the Service/Repair Manual from the Stickies, and see if there's some kind of linkage to distinguish F from R.

When you said "no reading" in forward, would that mean OL for the full range of the pedal, or 0?
yurtle is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-09-2019, 12:12 PM   #12
Not Yet Wild
 
Steve Kuczak's Avatar
Club Car
 
Join Date: Jan 2019
Location: Snow Hill, MD
Posts: 24
Default Re: Ez Go Marathon Not Working

When I said no reading I just meant that my meter read 0 when in forward but maxed my meter out (OL) in reverse.
Steve Kuczak is offline   Reply With Quote
Unread 04-09-2019, 12:25 PM   #13
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: Ez Go Marathon Not Working

Quote:
Originally Posted by Steve Kuczak View Post
When I said no reading I just meant that my meter read 0 when in forward but maxed my meter out (OL) in reverse.
Sorry, but did you get 0 ohms for the full range of the pedal in forward, and OL for the full range of the pedal in reverse? I thought you previously said it did go from 0 up to 600+ before hitting OL?

If you got 0 - 600+ then OL in forward, then forward seems to be working?
yurtle is offline   Reply With Quote
Unread 04-09-2019, 06:49 PM   #14
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 15,801
Default Re: Ez Go Marathon Not Working

Attached is a couple schematics of a pot-box Marathon with a pot-box throttle. First one shows in F and second shows in R.

When F/R is in F, the contact in MS-2 are open and only the 0-5KΩ pot is supposed to be between the black and white wires. When in F/R is in R, the MS-2 contacts are closed and a fixed 2.5KΩ is placed in parallel with the pot, so the throttle range is now 0-2.5KΩ. or half speed for reverse.

Apparently the electrical location of the fixed value resistor is wrong on the schematic. It ought to be on the MS-2 side of the pot-wiper connection.


BTW: if the resistance seen by the controller exceeds about 7KΩ, the controller shuts off as a safety feature, so a dirty or intermittent, or noisy pot can shut down the controller as well as an open pot.
JohnnieB is offline   Reply With Quote
Unread 04-10-2019, 06:27 AM   #15
Not Yet Wild
 
Steve Kuczak's Avatar
Club Car
 
Join Date: Jan 2019
Location: Snow Hill, MD
Posts: 24
Default Re: Ez Go Marathon Not Working

Yurtle- Sorry if I'm not being clear. I got 0 (pedal up) - 600+ then OL (pedal down) in reverse. When in forward the meter remained at 0 no matter what I did with the pedal.

JohnnieB- So based off that information I'm wondering if it got to above 7K ohms while in forward and shut the controller down. Would that explain why reverse has resistance (because it's limited to 2,500 ohms) but forward does not? It this happened, does that mean the controller is fried? Also.. If the controller is getting resistance in reverse I wonder why the cart still has no movement at least in reverse..
Steve Kuczak is offline   Reply With Quote
Unread 04-10-2019, 09:34 AM   #16
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 15,801
Default Re: Ez Go Marathon Not Working

Troubleshooting is a process of elimination. By eliminating the things that are good, you eventually end up with what is bad, or at least narrow done the list of likely suspects.

The solenoid clicks when the pedal is pushed, so that eliminates the solenoid activation circuit.
Full battery pack voltage is measured between B- and M- when pedal is pushed just far enough to make solenoid click, so that pretty much eliminates the high current cables and F/R switch. (I qualify because measuring with a voltmeter isn't the same as operating with high current flowing)

The voltage between B- and M- doesn't decrease when pedal is pushed further, so either the controller or throttle is bad.

The Ohmic values for the throttle are not what they ought to be, so we cannot determine if controller is good or bad until the throttle failure is corrected.

Fix the throttle and either the cart will work, or further troubleshooting is needed.
JohnnieB is offline   Reply With Quote
Unread 04-10-2019, 12:41 PM   #17
Not Yet Wild
 
Steve Kuczak's Avatar
Club Car
 
Join Date: Jan 2019
Location: Snow Hill, MD
Posts: 24
Default Re: Ez Go Marathon Not Working

Ok I'll replace the throttle and report back. Thanks!!
Steve Kuczak is offline   Reply With Quote
Unread 04-10-2019, 01:10 PM   #18
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,988
Default Re: Ez Go Marathon Not Working

Quote:
Originally Posted by Steve Kuczak View Post
Ok I'll replace the throttle and report back. Thanks!!
That's one way. Another might be to borrow a meter that can measure the resistance of the pot, since yours is only rated up to 600 ohms, and see what's really going on. Your pot box "apparently" acts differently in forward than in reverse, but cart doesn't go in either direction.

Quote:
Originally Posted by Steve Kuczak View Post
I got 0 (pedal up) - 600+ then OL (pedal down) in reverse. When in forward the meter remained at 0 no matter what I did with the pedal.
It's variable in reverse but not in forward. Could the fixed resister be shorted?
yurtle is offline   Reply With Quote
Unread 04-13-2019, 10:05 AM   #19
72 volts!
 
Andy4639's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Liberty SC, Garden City SC
Posts: 5,692
Thumbs up Re: Ez Go Marathon Not Working

You could have the F/R cam out. It has to be in the right position are it want send the juice.
Andy4639 is offline   Reply With Quote
Unread 04-15-2019, 08:42 AM   #20
Not Yet Wild
 
Steve Kuczak's Avatar
Club Car
 
Join Date: Jan 2019
Location: Snow Hill, MD
Posts: 24
Default Re: Ez Go Marathon Not Working

Yurtle- I thought about what you said and took the pot apart to inspect the resistor which turned out to be fine. Everything looked good that I inspected.

Andy- I kind of think it does have to do with the FNR switch. When I first replaced the FNR switch after the wire burnt up the cart worked fine 1 time. When I tried to take it for a test run it wouldn't go in forward anymore. But I still had reverse. I ended up finding a corroded wired from the FNR switch to the battery pack which I cleaned up and reconnected. Then I lost reverse when I tried it out. Then I figured it had to be the controller so I replaced that. Still nothing after replacing the controller.. Are there some sort of guidelines for adjusting the FNR switch?
Steve Kuczak is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
94 ezgo marathon stopped working Electric EZGO
EZGO Marathon Suddenly Stopped Working Electric EZGO
working on an '82 marathon Gas EZGO
Marathon Reverse Not Working Gas EZGO
Marathon 48 volt upgrade done and working Thanks! Electric EZGO


All times are GMT -5. The time now is 07:17 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.