lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-05-2019, 11:09 AM   #1
Not Yet Wild
 
Steve Kuczak's Avatar
Club Car
 
Join Date: Jan 2019
Location: Snow Hill, MD
Posts: 24
Default Ez Go Marathon Not Working

Hello everyone,

I have a 1992 Ez Go marathon that is giving me trouble. Basically it all started when I was operating it at a slower speed and a wire on the FNR switch burnt up. I replaced the switch with a HD one and then I also replaced the controller after the switch didn't solve the problem. When I press the pedal the solenoid clicks but nothing else happens. Can someone please give me suggestions on how to troubleshoot it from here?

Thanks- Steve
Steve Kuczak is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-05-2019, 12:26 PM   #2
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 15,332
Default Re: Ez Go Marathon Not Working

Could be a bad motor or a bad controller or a bad throttle or a bad amp delivery circuit or a combination thereof.

Connect a DVM between the controller's B- and M- terminals and press pedal just far enough to make solenoid click. If you read battery pack voltage (about 38.2V when fully charged), the amp delivery circuit is intact.

If you get battery pack voltage, slowly press pedal to floor and voltage should smoothly decrease to zero.

If it doesn't, check the pot-box throttle.

If it does, check the motor.
JohnnieB is offline   Reply With Quote
Unread 04-08-2019, 10:04 AM   #3
Not Yet Wild
 
Steve Kuczak's Avatar
Club Car
 
Join Date: Jan 2019
Location: Snow Hill, MD
Posts: 24
Default Re: Ez Go Marathon Not Working

Thanks for the reply JohnnieB, I really appreciate it. So I did your test and the voltage did not decrease when I pressed the pedal down. Where is the pot-box throttle and how do I check it? Thanks again.
Steve Kuczak is offline   Reply With Quote
Unread 04-08-2019, 11:14 AM   #4
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 15,332
Default Re: Ez Go Marathon Not Working

Lift he seat and look in front of the controller while pressing pedal and you ought to see some rods and levers moving.

To check, remove the black and white wires from controller and connect an Ohmmeter between the wires.

Should be close to 0Ω with pedal up and close to 5,000Ω with pedal down.
JohnnieB is offline   Reply With Quote
Unread 04-09-2019, 06:41 AM   #5
Not Yet Wild
 
Steve Kuczak's Avatar
Club Car
 
Join Date: Jan 2019
Location: Snow Hill, MD
Posts: 24
Default Re: Ez Go Marathon Not Working

I tested the two wires, but my DVM doesn't read/register above 600 ohms it looks like. It there another way to test it?
Steve Kuczak is offline   Reply With Quote
Unread 04-09-2019, 07:56 AM   #6
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,940
Default Re: Ez Go Marathon Not Working

Did the resistance go up from 0Ω to 600Ω as you pressed the pedal? Does your meter maybe have a kΩ setting? That's 1,000Ω.
yurtle is offline   Reply With Quote
Unread 04-09-2019, 09:29 AM   #7
Not Yet Wild
 
Steve Kuczak's Avatar
Club Car
 
Join Date: Jan 2019
Location: Snow Hill, MD
Posts: 24
Default Re: Ez Go Marathon Not Working

Yes it went from 0 ohms up to about 630 ohms before the meter read OL (overload?). It is a Fluke 333 clamp meter.
Steve Kuczak is offline   Reply With Quote
Unread 04-09-2019, 09:31 AM   #8
Not Yet Wild
 
Steve Kuczak's Avatar
Club Car
 
Join Date: Jan 2019
Location: Snow Hill, MD
Posts: 24
Default Re: Ez Go Marathon Not Working

Also, I only get those readings when the cart is in reverse. When it's in forward, I get no readings at all.
Steve Kuczak is offline   Reply With Quote
Unread 04-09-2019, 10:10 AM   #9
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,940
Default Re: Ez Go Marathon Not Working

I just looked up the specs, and sure enough, your Fluke 333 only goes to 600 ohms. Can you borrow one, or buy a cheap +/- $20 one at a local Home Depot, Lowes, Walmart, Ace, Auto Zone, etc.?

If your controller doesn't see 0Ω to +/- 5000Ω, it won't go. I'm not familiar with a pot box, but I'm pretty sure it only goes from 0Ω tp 2500Ω, or half speed, in reverse, so I'd think you'd read 0Ω to 600Ω in reverse, but have to press the pedal farther in reverse to get OL.
yurtle is offline   Reply With Quote
Unread 04-09-2019, 11:21 AM   #10
Not Yet Wild
 
Steve Kuczak's Avatar
Club Car
 
Join Date: Jan 2019
Location: Snow Hill, MD
Posts: 24
Default Re: Ez Go Marathon Not Working

Ok I'll have to get a different meter then. Do you have any idea why it wouldn't be registering while in forward? I just replaced the FNR switch.
Steve Kuczak is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
94 ezgo marathon stopped working Electric EZGO
EZGO Marathon Suddenly Stopped Working Electric EZGO
working on an '82 marathon Gas EZGO
Marathon Reverse Not Working Gas EZGO
Marathon 48 volt upgrade done and working Thanks! Electric EZGO


All times are GMT -5. The time now is 12:57 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.