lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-12-2019, 08:00 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: May 2019
Location: GA
Posts: 4
Default 2014 RXV Problem

My 2014 RXV has been Great, till now. Was backing out of the garage and it stopped, locked up. Had to use the Aux. power deal to get back into garage,
Electric break seems to lock it out no matter what. Any ideas on what I should do?
Gator01 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-12-2019, 09:04 PM   #2
Gone Wild
 
kgsc's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 7,001
Default Re: 2014 RXV Problem

A handheld programmer is your best friend right now. It will tell you what what is failing in the circuit to cause the cart to kick out the circuit. Where are you located in Georgia?
kgsc is offline   Reply With Quote
Unread 05-12-2019, 10:46 PM   #3
Gone Wild
 
nickdalzell1's Avatar
 
Join Date: Oct 2011
Posts: 433
Default Re: 2014 RXV Problem

If it's the brake that failed no handheld gives a code for it (Danahar variants way back would throw a brake slipping error though)

That being said the RXVs default means of conveying an error to the user is by throwing him or her through the windshield.

Put it in Tow and key to N(on) and see if you can push it freely. If it starts fighting you, or cant move a lick it will narrow it down to the speed sensor in the motor or throttle encoder in the pedal group.
nickdalzell1 is offline   Reply With Quote
Unread 05-13-2019, 05:36 AM   #4
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 8,812
Default Re: 2014 RXV Problem

Quote:
Originally Posted by nickdalzell1 View Post
That being said the RXVs default means of conveying an error to the user is by throwing him or her through the windshield.
yurtle is offline   Reply With Quote
Unread 05-13-2019, 06:09 AM   #5
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 13,097
Default Re: 2014 RXV Problem

Curtis code for failed motor brake is "EM brake slipping", not "there is no code for that". It will show that in the "current errors" section when it happens. It will also list "EM brake failed to set" in the error history.
cgtech is offline   Reply With Quote
Unread 05-13-2019, 02:38 PM   #6
Not Yet Wild
E-Z-GO
 
Join Date: May 2019
Location: GA
Posts: 4
Default Re: 2014 RXV Problem

It won't move at all when I switch to tow mode. I was able to disengage the brake with the aux power described under the tow/run cover. when I put back in run mode after everything is back to normal it seems to shift the motor forward and reverse then engages the brake again and wont move. Was thinking possible the solenoid? But from these responses, maybe speed sensor is that a hard change out?
Gator01 is offline   Reply With Quote
Unread 05-15-2019, 10:35 AM   #7
Not Yet Wild
E-Z-GO
 
Join Date: May 2019
Location: GA
Posts: 4
Default Re: 2014 RXV Problem

Update:
I checked the two fuses on the Run/Tow cover. They were both corroded, the motor break more so that the other. Couldn't clean down in the fuse holder very well. Also checked the run plug jumper, it appears to be corroded as well. After that I tried the cart and it did move in forward and reverse once then the same thing, it locked the break. Don't know if it was just a fluke or is the RXV that sensitive to current and could the corrosion be the problem?
Gator01 is offline   Reply With Quote
Unread 05-15-2019, 08:51 PM   #8
Gone Wild
 
nickdalzell1's Avatar
 
Join Date: Oct 2011
Posts: 433
Default Re: 2014 RXV Problem

Cg I've never seen that particular code but I'm sure I haven't seen them all yet. A bad (burnt) brake doesnt throw a code I've seen yet. Anytime I've seen EM brake errors it often means the controller EOL'd. As is usually the case with the most common one, EM Brake Driver OC.
nickdalzell1 is offline   Reply With Quote
Unread 05-20-2019, 09:50 PM   #9
Not Yet Wild
E-Z-GO
 
Join Date: May 2019
Location: GA
Posts: 4
Default Re: 2014 RXV Problem

Got it up and running. Thanks for the info and help.
Gator01 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2014 BBB Recoil IS 72V Problem Electric golf carts
2014 TXT 48v? Electric EZGO
2014 RXV? yes or no Electric EZGO
2014 XRT 850 gas anyone have one. Gas Club Car


All times are GMT -5. The time now is 10:43 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.