lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-12-2019, 09:20 AM   #1
Not Yet Wild
 
Join Date: Jun 2019
Posts: 6
Default 2015 RXV's inop after charging

Hey guys, I have a 2 2015 RXV's with the same issue. Just an FYI, we have basically all club cars that are gas and I dont have a huge background in the ezgo electric carts. The first one I was told it wasnt taking a charge, so I towed it into the shop to check it out. The charger is a delta-q SC-48, would be making a relay-click sound every time the green light would blink. So i tried the other charger and it just made its normal charger sounds. I went to the clubhouse to grab the other RXV which I drove back to the shop and all was fine. I decided to plug the clicking charger into the one I just drove in to see if it did the same thing, and it did. I unplugged the charger and was going to drive it back and i got nothing.. no buzzer in reverse nothing in forward. I did get the amber light on the battery gauge for a blink of a sec when put into gear. So my question is it possible to have a charger do this to both vehicles? Both vehicles are fully charged. I've tried to look around and see if anything was similar but I came up empty handed. I appreciate any help thanks!
melinger is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-12-2019, 02:03 PM   #2
Getting Wild
 
OttyFields's Avatar
E-Z-GO
 
Join Date: Mar 2019
Location: Elizabethtown, IN
Posts: 121
Default Re: 2015 RXV's inop after charging

Have you taken the cover off that the run tow switch is attached to and make sure the 7.5 amp fuse is not blown?
There is also a 10 amp fuse under there you should check too. Sounds like you have a charger problem.
OttyFields is offline   Reply With Quote
Unread 06-12-2019, 03:04 PM   #3
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 13,817
Default Re: 2015 RXV's inop after charging

First- stop plugging the "clicky" charger into stuff. That charger is broken, and possible "angel of death".

Second, try tow/run switch to Tow position, then key in neutral. If it refuses to unlock, the charge port may be damaged, and sending false "charger is plugged in" signal. This could be confirmed by unplugging the blue wire at the charger port, and checking for power on the port side of the blue wire. If no voltage is found, that's the signal for "charger is plugged in". Any voltage over 16v is the signal for "charger not plugged in, all ok".
cgtech is offline   Reply With Quote
Unread 06-13-2019, 06:56 AM   #4
Not Yet Wild
 
Join Date: Jun 2019
Posts: 6
Default Re: 2015 RXV's inop after charging

Ok thanks for the tips. The 5 fuses I have found are all 10 amp, and all ok. I tried putting them in tow mode and in neutral and got no movement. But if i swap the 2 plugs under the tow cover it does unlock the brake. I also unplugged the blue wire and got 0 volts on both vehicles. What has really confused me is that a service manager at an ez-go dealer said that a charger could not do anything like this. I'll need another place to purchase a new charger and 2 charger ports from.. should I stay with factory ports and charger or do they make better aftermarket ones?
melinger is offline   Reply With Quote
Unread 06-13-2019, 09:18 AM   #5
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 13,817
Default Re: 2015 RXV's inop after charging

There are better chargers, but the ports are only made by delta-q for ezgo.

Also, the "the jumpers can unlock it" don't really matter to me, because that method totally bypasses the controller, and sends more power than usual to the brake. It can't be driven like that anyway.
cgtech is offline   Reply With Quote
Unread 06-13-2019, 09:36 AM   #6
Not Yet Wild
 
Join Date: Jun 2019
Posts: 6
Default Re: 2015 RXV's inop after charging

Any particular brand/model charger that you can recommend?
melinger is offline   Reply With Quote
Unread 06-13-2019, 09:38 AM   #7
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 13,817
Default Re: 2015 RXV's inop after charging

Check out ScottyB's store. www.cartsunlimited.net
cgtech is offline   Reply With Quote
Unread 06-13-2019, 09:50 AM   #8
Not Yet Wild
 
Join Date: Jun 2019
Posts: 6
Default Re: 2015 RXV's inop after charging

Thanks so much for your help good sir!
melinger is offline   Reply With Quote
Unread 06-19-2019, 06:44 AM   #9
Not Yet Wild
 
Join Date: Jun 2019
Posts: 6
Default Re: 2015 RXV's inop after charging

Update- I got the new charger ports installed, worked like a charm! Thanks again!
melinger is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Need Sticky Threads for RXV's Electric EZGO
Random.....why aren't RXV's more popular? Electric EZGO
Tomberlin speedometer inop Tomberlin
Charger inop Electric EZGO
Lights inop Electric Club Car


All times are GMT -5. The time now is 09:37 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.