lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-11-2019, 10:35 AM   #1
Not Yet Wild
 
Join Date: May 2019
Posts: 7
Default 2013 - Inconsistent Power

Sometimes it has more get up and go than other times, more power, faster acceleration. Brand new batteries and cables. Always runs and moves at a decent pace, never a crawling pace since changing the batteries.

Could a failing solenoid be the problem? Any other ideas? Thanks!
WVUDave is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-11-2019, 10:50 AM   #2
Not Yet Wild
Mixed Breed
 
Join Date: May 2019
Location: Georgia
Posts: 56
Default Re: 2013 - Inconsistent Power

what knid of cart, year, make, model, you change the batteries, do you keep the same ah rating, how about the state of charge? Are the cable good and tight. Crawling could be a sigh of a bad speed sensor. just a tought
LabRat is offline   Reply With Quote
Unread 07-11-2019, 11:05 AM   #3
Not Yet Wild
 
Join Date: May 2019
Posts: 7
Default Re: 2013 - Inconsistent Power

2013 EZGO TXT. It no longer crawls, not since I replaced the batteries. No click when key turned to on. Was worse with the old batteries.
WVUDave is offline   Reply With Quote
Unread 07-11-2019, 12:06 PM   #4
Not Yet Wild
 
Join Date: May 2019
Posts: 7
Default Re: 2013 - Inconsistent Power

It used to take off quicker and accelerate faster than it is now. Goes slightly slower on inclines as well. Runs consistently though since changing batteries. Any ideas?
WVUDave is offline   Reply With Quote
Unread 07-11-2019, 01:53 PM   #5
Not Yet Wild
 
Join Date: May 2019
Posts: 7
Default Re: 2013 - Inconsistent Power

Reduced performance at times
WVUDave is offline   Reply With Quote
Unread 07-11-2019, 08:31 PM   #6
Gone Wild
E-Z-GO
 
Join Date: Sep 2018
Location: Md.
Posts: 316
Default Re: 2013 - Inconsistent Power

Like asked. All battery cable connections tight. Any cables get warm compared to others?
Individual battery voltages and hydrometer readings after a charge and pack voltage under load good?
It is possible even tho new to have a bad battery.
Just throwing out some basic checks 😊
Cobra,1 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2013 Precedent will not move under power Electric Club Car
2013 Yamaha EFI lacking power... Gas Yamaha
2013 TXT need more torque and lower end power Gas EZGO
power tour 2013 Announcements
1999 G19E Relay problem /inconsistent power Electric Yamaha


All times are GMT -5. The time now is 08:09 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.