lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-13-2019, 02:10 PM   #1
Not Yet Wild
Mixed Breed
 
Join Date: Nov 2019
Location: North Carolina
Posts: 4
Default 2019 s4 72volt having issues

Someone had used a Curtis handheld to speed this cart up, and now itís having several issues. The voltage in the battery pack is 94 volts, which seems high. Also the charge indicator will only show 77% charge. The cart will also drive with the charger plugged in. Iím wondering if there is any way to reset the controller to factory settings or is it possible the controller is corrupted?
Choppajay is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-13-2019, 07:55 PM   #2
Gone Insane
E-Z-GO
 
Join Date: Oct 2015
Location: TN/NC/GA Tri-state area
Posts: 3,266
Default Re: 2019 s4 72volt having issues

Quote:
Originally Posted by Choppajay View Post
Someone had used a Curtis handheld to speed this cart up, and now itís having several issues. The voltage in the battery pack is 94 volts, which seems high. Also the charge indicator will only show 77% charge. The cart will also drive with the charger plugged in. Iím wondering if there is any way to reset the controller to factory settings or is it possible the controller is corrupted?
I usually won't touch a 72V L6 or S4 that's been corrupted by some ***** messing with something they know nothing about. But I'm probably the only guy that would have the correct factory file from Curtis that could be used to reflash your controller back to normal, then do the speedup the correct way. Where are you located?

Bob
BobBoyce is offline   Reply With Quote
Unread 11-13-2019, 08:49 PM   #3
Not Yet Wild
Mixed Breed
 
Join Date: Nov 2019
Location: North Carolina
Posts: 4
Default Re: 2019 s4 72volt having issues

I am in Eastern North Carolina. This one has been a real mind bender for me.
Choppajay is offline   Reply With Quote
Unread 11-13-2019, 11:48 PM   #4
Gone Insane
E-Z-GO
 
Join Date: Oct 2015
Location: TN/NC/GA Tri-state area
Posts: 3,266
Default Re: 2019 s4 72volt having issues

Quote:
Originally Posted by Choppajay View Post
I am in Eastern North Carolina. This one has been a real mind bender for me.
It's a protected controller. Which means, while a handset can be used to change values, if it is not unlocked properly first, any changes made will cause the controller to malfunction. To restore operation, it must be returned exactly to the settings it was delivered with. Even setting the profile for 1/10 of a MPH higher will mess it up. Dealers don't know these new controllers and mess them up all the time when trying to help the customer. Usually, they have to put in a new controller to fix it.

I'm preparing for another trip to cover NC/GA/SC/FL/AL/LA in the very near future. You can use the PM system now, so send a PM to usgicollector and have him put you on the list...

Bob
BobBoyce is offline   Reply With Quote
Unread 11-14-2019, 10:57 AM   #5
Not Yet Wild
Mixed Breed
 
Join Date: Nov 2019
Location: North Carolina
Posts: 4
Default Re: 2019 s4 72volt having issues

Thank you Bob, I will be in touch.
Choppajay is offline   Reply With Quote
Unread 11-14-2019, 01:33 PM   #6
Gone Wild
 
kgsc's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 7,386
Default Re: 2019 s4 72volt having issues

Bob, just for knowledge sake. Does it prompt you when you connect to it for a password or unlock sequence or do you just have to know where go in the menus to tell it with credentials to unlock. If you don't want to post that info here I understand. Curtis is already upset with us messing with their stuff..
kgsc is offline   Reply With Quote
Unread 11-15-2019, 12:21 AM   #7
Gone Insane
E-Z-GO
 
Join Date: Oct 2015
Location: TN/NC/GA Tri-state area
Posts: 3,266
Default Re: 2019 s4 72volt having issues

Quote:
Originally Posted by kgsc View Post
Bob, just for knowledge sake. Does it prompt you when you connect to it for a password or unlock sequence or do you just have to know where go in the menus to tell it with credentials to unlock. If you don't want to post that info here I understand. Curtis is already upset with us messing with their stuff..
No, it does not prompt you for a password. It acts like all is normal and ok, until you make a change to a protected value, then try to operate it. Suddenly, you find that not all is well. If you reverse what you changed, it goes back to normal. If you make another change, further away from the factory settings, it corrupts further. Several steps in, your only way back is to reflash it with a factory file, as you've lost track of all the changes made and normal operation is lost. If you lead with the unlock procedure, and wait for the response, you will see the menu options change. At that point, your changes will not corrupt the controller. If people had not spread the interface hack far and wide without consideration for how that affects Curtis, Curtis would not have been forced to introduce countermeasures and come out with a new interface to support a newer communications protocol that renders older programming interfaces obsolete. The 2020 controllers require that new interface.
BobBoyce is offline   Reply With Quote
Unread 11-15-2019, 08:03 AM   #8
Gone Wild
 
kgsc's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 7,386
Default Re: 2019 s4 72volt having issues

Thanks for the explanation sir. I guess this means if you don’t know what you are doing don’t attempt it but if you do try you better take a snapshot before you start. And even that may not save you.
kgsc is offline   Reply With Quote
Unread 11-15-2019, 12:39 PM   #9
Gone Insane
E-Z-GO
 
Join Date: Oct 2015
Location: TN/NC/GA Tri-state area
Posts: 3,266
Default Re: 2019 s4 72volt having issues

Quote:
Originally Posted by kgsc View Post
Thanks for the explanation sir. I guess this means if you donít know what you are doing donít attempt it but if you do try you better take a snapshot before you start. And even that may not save you.
Even saving a file prior will not save anyone that does not have compatible Curtis hardware and software. Even those custom interfaces that you and usgicollector now have will not be usable for a full reflash. I have since become aware that there was corruption in the interface. Salvaging a corrupted controller requires programming equipment that can completely write compiled OS/VCL files to that controller. I had to buy new hardware myself that is compatible with late 2019 and all 2020 controllers that I had worked on.
BobBoyce is offline   Reply With Quote
Unread 11-15-2019, 12:49 PM   #10
Gone Wild
 
kgsc's Avatar
E-Z-GO
 
Join Date: Dec 2009
Location: Aiken, SC
Posts: 7,386
Default Re: 2019 s4 72volt having issues

Good to know. Saving the snapshot would be at least good to send with the controller when it has to get reflashed.. I think I am just going to quit touching carts for fear I might break something.. If I need changes I know this guy I can get in touch with.
kgsc is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2019 Onward Kohler Issues Gas Club Car
2019 ezgo txt 72v issues Electric EZGO
72volt CC XRT 810E motor help Extreme DC!
THA BIG NASTY 72volt beast Lifted Golf Carts
my 72volt creation Electric Club Car


All times are GMT -5. The time now is 04:55 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.