lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-01-2019, 04:47 PM   #1
Not Yet Wild
 
Join Date: Apr 2019
Posts: 20
Default RXV just stops and loses power

2016 RXV 48 volt

The cart has recently started just "dying" while driving. We'll be riding and the cart will lose all power and skid to a stop. Also started recently, when the key is turned on, there's none of the sounds you normally here when the motor brake disengages. Since I'm new to the golf cart community, I have no idea where to begin to troubleshoot. Any help would be appreciated.
ADSFR075 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-01-2019, 05:44 PM   #2
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 14,217
Default Re: RXV just stops and loses power

One likely cause is encoder failure, or corrosion In the harness leading to the encoder. But, i would first monitor pack voltage while driving.
cgtech is online now   Reply With Quote
Unread 12-01-2019, 06:10 PM   #3
Not Yet Wild
 
Join Date: Apr 2019
Posts: 20
Default Re: RXV just stops and loses power

It stopped in the driveway today, so I checked the batteries with my voltage meter and the meter showed 51.9. The cart is now in the garage, after taking forever to eventfully run again. Turn the key on and the battery meter moves, but the cart wont do anything. The meter is now showing 52.1.
ADSFR075 is offline   Reply With Quote
Unread 12-01-2019, 06:13 PM   #4
Over This Interview Is...
 
cgtech's Avatar
Yamaha
 
Join Date: Jun 2012
Location: AZ
Posts: 14,217
Default Re: RXV just stops and loses power

Static voltage isn't what we need anyway, needs to be while driving. Unfortunately, testing the encoder requires a oscilloscope, or the curtis diagnostics tool to look for "encoder fault".
cgtech is online now   Reply With Quote
Unread 12-01-2019, 08:46 PM   #5
Not Yet Wild
 
Join Date: Apr 2019
Posts: 20
Default Re: RXV just stops and loses power

Right now it won't do anything, and i certainly don't have one of those oscilloscopes, so I guess its off to the shop we go, unless you have another suggestion.
ADSFR075 is offline   Reply With Quote
Unread 12-02-2019, 06:55 PM   #6
Not Yet Wild
 
Join Date: Aug 2012
Posts: 69
Default Re: RXV just stops and loses power

Quote:
Originally Posted by ADSFR075 View Post
Right now it won't do anything, and i certainly don't have one of those oscilloscopes, so I guess its off to the shop we go, unless you have another suggestion.
Before I took it the shop, I'd clean all the cables and make sure they are tight and in good condition. Replace them with quality ones if there is any doubt. RXV's are very susceptible to voltage drops and bad cables was the issue I had on mine, when I had the same symptoms as you report.
buckeyejudge is online now   Reply With Quote
Unread 12-02-2019, 09:46 PM   #7
Not Yet Wild
 
Carts4you's Avatar
 
Join Date: Sep 2018
Posts: 74
Default Re: RXV just stops and loses power

Quote:
Originally Posted by cgtech View Post
One likely cause is encoder failure, or corrosion In the harness leading to the encoder. But, i would first monitor pack voltage while driving.
We have a 2010 RXV doing a similar stop. After a few minutes it will start again. We are thinking motor overheating or temp sensor failing. Using the Danaher scanner we found motor temp under warnings. We were recommended by a tech to change the motor, but after doing so it still shows same warning. We are checking the cables from motor temp sensor to controller to make sure it is good. If it is, next possible cause can be controller.
Carts4you is offline   Reply With Quote
Unread 12-03-2019, 11:58 AM   #8
Not Yet Wild
 
Join Date: Apr 2019
Posts: 20
Default Re: RXV just stops and loses power

Quote:
Originally Posted by buckeyejudge View Post
Before I took it the shop, I'd clean all the cables and make sure they are tight and in good condition. Replace them with quality ones if there is any doubt. RXV's are very susceptible to voltage drops and bad cables was the issue I had on mine, when I had the same symptoms as you report.
I called a local battery shop yesterday, and it seems that for just a few dollars I can get quality 2g cables. Hope to have them installed by this weekend to see if that helps. Thanks for your reply.
ADSFR075 is offline   Reply With Quote
Unread 12-03-2019, 12:01 PM   #9
Not Yet Wild
 
Join Date: Apr 2019
Posts: 20
Default Re: RXV just stops and loses power

Quote:
Originally Posted by Carts4you View Post
We have a 2010 RXV doing a similar stop. After a few minutes it will start again. We are thinking motor overheating or temp sensor failing. Using the Danaher scanner we found motor temp under warnings. We were recommended by a tech to change the motor, but after doing so it still shows same warning. We are checking the cables from motor temp sensor to controller to make sure it is good. If it is, next possible cause can be controller.
When the cart stopped on Sunday, I felt to see if the motor was hot, and is wasn't. I'll be anxious to hear what you find as the ultimate cause.
ADSFR075 is offline   Reply With Quote
Unread 12-04-2019, 07:48 AM   #10
Gone Wild
E-Z-GO
 
Join Date: Aug 2012
Location: Houma, Louisiana
Posts: 654
Default Re: RXV just stops and loses power

Just out of curiosity, any burning type smells coming from the motor/brake area? Is the motor brake on the driver side of the motor hot when it locks up? Mine did something very similar and it turned out to be the motor brake that had went south on me. After letting it cool for a while, I could drive it again for a short distance, then it would lock again.
jneubig is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2009 RXV 4: suddenly stops and loses power after hitting bump Electric EZGO
1988 G2 Runs then slowly loses power and stops. Gas Yamaha
1997 EZGO TXT loses power and stops Electric EZGO
'08 RXV suddenly loses power Electric EZGO
2005 Precedent starts of powered, then loses power, reverse always power Electric Club Car


All times are GMT -5. The time now is 02:53 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.