lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-08-2009, 05:19 PM   #1
Not Yet Wild
 
Join Date: Jun 2009
Posts: 7
Default shuttering???

my 36 volt ez go cart waws running fine yesterday and this morning with 1/2 charge on the battery gauge, now in any direction it barely tries to move and then just shutters?? jacked up the reaer end and wheels turn freely in both directions but not as fast as they should be
drive motor brushes?
thanks
boydog40 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-08-2009, 05:23 PM   #2
doin it in the desert
 
dock98's Avatar
Yamaha
 
Join Date: Dec 2008
Location: Sonora Desert,Az
Posts: 5,603
Default Re: shuttering???

welcome to BGW. boydog40. i hope you mean shuddering?
dock98 is offline   Reply With Quote
Unread 06-08-2009, 05:23 PM   #3
Not Yet Wild
 
Join Date: Jun 2009
Posts: 7
Default Re: shuttering???

thanks
boydog40 is offline   Reply With Quote
Unread 06-08-2009, 05:25 PM   #4
Not Yet Wild
 
Join Date: Jun 2009
Posts: 7
Default Re: shuttering???

thanks, sorry for double reply, have been browsing this forum looking for similar problems but no luck so far
boydog40 is offline   Reply With Quote
Unread 06-08-2009, 05:44 PM   #5
Not Yet Wild
 
Join Date: Jun 2009
Posts: 7
Default Re: shuttering???

yes shuddering thanks for correcting my misspelling!!
anyway just fixed it, was a loose wire on one battery, shut the whole cart down for one loose wire, so maybe this will help others, keep your wires clean and tight
thanks guys
boydog40 is offline   Reply With Quote
Unread 06-08-2009, 09:03 PM   #6
Raised by coyotes
 
Flintrock's Avatar
Yamaha
 
Join Date: Nov 2008
Location: Central Texas
Posts: 5,632
Default Re: shuttering???

Thanks for the update and solution!! Every bit of info will help someone else out..
Flintrock is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 12:45 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.