lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 07-11-2009, 09:20 PM   #1
Getting Wild
 
jonnymoon5's Avatar
E-Z-GO
 
Join Date: Jul 2009
Location: New Jersey
Posts: 120
Exclamation 1989 EZGO Marathon Electrical Problems

I have a 1989 ez go marathon with many problems that i need to know if they're repairable and what i need to do to repair them

First off, it seems like the speed controller is dead or broken. It goes from 0-full speed theres no in between

Secondly, the batteries hold little to no charge

Finally, it makes this weird grinding noise when i'm driving

Any help would be GREATLY appreciated

Thanks
jonnymoon5 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 07-12-2009, 10:01 AM   #2
steeplejack x
 
pggroves's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Republic of Texas
Posts: 3,332
Default Re: 1989 EZGO Marathon Electrical Problems

Quote:
Originally Posted by jonnymoon5 View Post
I have a 1989 ez go marathon with many problems that i need to know if they're repairable and what i need to do to repair them

First off, it seems like the speed controller is dead or broken. It goes from 0-full speed theres no in between

Might be a throttle issue. If controller was bad prob wouldn't go at all.

Secondly, the batteries hold little to no charge

How old?

Finally, it makes this weird grinding noise when i'm driving

Check the castle nuts on the rears. Hubs (brake drums) are splined and are a known weak spot in drive system.

Any help would be GREATLY appreciated

Thanks

Suggest gut/rewire. Here's a diagram to start you off.

Good luck!
Attached Images
File Type: jpg Marathon Controller Wiring Diagram.jpg (53.8 KB, 54 views)
pggroves is offline   Reply With Quote
Old 07-12-2009, 03:08 PM   #3
Getting Wild
 
jonnymoon5's Avatar
E-Z-GO
 
Join Date: Jul 2009
Location: New Jersey
Posts: 120
Default Re: 1989 EZGO Marathon Electrical Problems

the batteries are 3 2009 deka and 3 2008 i believe energizer

this is my first cart so i'm still learning parts on the engine and drive system. where are the castle nuts and what in the brake drums should i be looking at

thanks
-Jm5
jonnymoon5 is offline   Reply With Quote
Old 07-12-2009, 08:58 PM   #4
steeplejack x
 
pggroves's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Republic of Texas
Posts: 3,332
Default Re: 1989 EZGO Marathon Electrical Problems

OK
For the batteries:
Start by checking individual battery voltages and also check each cell's specific gravity. Post results here and someone can identify any problem areas if you need it. Check voltages while charging. Especially at beginning of charge and near end of charge cycle. Note amps at each time as well.
Grinding noise:
The brake drums are splined to mate to the splined ends of the axle shaft. Remove the rear wheel and you'll see the castle nut. It also may just be worn out brake shoes scraping against the drum. Either way, you need to tear down and inspect.

Of course, if any of this is outside your comfort level and you're in Texas (within a reasonable commute) then let me know and I can take that problem child off your hands.
pggroves is offline   Reply With Quote
Old 07-20-2009, 10:48 PM   #5
Getting Wild
 
jonnymoon5's Avatar
E-Z-GO
 
Join Date: Jul 2009
Location: New Jersey
Posts: 120
Default Re: 1989 EZGO Marathon Electrical Problems

the battery part was fixed. i replaced the energizer batteries. one was melting so i replaced the whole set and it holds a charge. the brakes are only working on one side so i adjusted it and its still making the noise. it's out of my ideas so i'm taking it to a repair shop. thanks for the help
jonnymoon5 is offline   Reply With Quote
Old 07-31-2011, 04:35 PM   #6
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2011
Location: Topeka, Kansas
Posts: 16
Default Re: 1989 EZGO Marathon Electrical Problems

I had an 89 EZGO also and had to replace the coils and solenoid. I also had the problem with going in high speed also and noticed that the wiper contacts were welded together from electrical arcing as the wiper assembly traveled across them. I took a hacksaw blade and filed in between the contacts to break the weld. Works great now and it fixed the speed problem. Hope that helps.
tbrian76 is offline   Reply With Quote
Old 07-31-2011, 06:35 PM   #7
Getting Wild
 
jonnymoon5's Avatar
E-Z-GO
 
Join Date: Jul 2009
Location: New Jersey
Posts: 120
Default Re: 1989 EZGO Marathon Electrical Problems

woah digging up a dead topic much? problems been resolved
jonnymoon5 is offline   Reply With Quote
Old 07-31-2011, 06:44 PM   #8
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2011
Location: Topeka, Kansas
Posts: 16
Default Re: 1989 EZGO Marathon Electrical Problems

Good news. Are you saying that someone else had the same issue? I guess I missed it in the thousands of posts I checked, none of which referred to welded contacts on the wiper board. Probably the most inexpensive fix I've had. All the reading just blurred together after a while. Even though, it's great to have a resource when you need help. I can't seem to find too many mechanics around my area that have much experience with carts. Nice to find a community of knowledgable and enthusiastic cart supporters.
tbrian76 is offline   Reply With Quote
Old 07-31-2011, 09:43 PM   #9
Getting Wild
 
jonnymoon5's Avatar
E-Z-GO
 
Join Date: Jul 2009
Location: New Jersey
Posts: 120
Default Re: 1989 EZGO Marathon Electrical Problems

i figured out that my issue was a solenoid issue, not the board. but it was replaced during the resto and she's working like a champ now. just wish the charger was working that good
jonnymoon5 is offline   Reply With Quote
Old 07-31-2011, 09:46 PM   #10
Carts Unlimited
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: So Cal
Posts: 51,208
Default Re: 1989 EZGO Marathon Electrical Problems

It is always good to have these repairs resolved and documented ~ It makes for more useful archives.....
scottyb is offline   Reply With Quote
Reply

Tags
1989, ez go marathon, ezgo, marathon
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
More eletrical Problems 1989 EZGO Gas EZGO
1989 ezgo marathon Electric EZGO
Electrical Problems Electric EZGO
Small electrical upgrade. 1980 EZGO Marathon Garage and Workshop
1989 2 Stroke Problems Gas EZGO


All times are GMT -5. The time now is 09:41 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.