lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-23-2009, 08:24 PM   #1
Not Yet Wild
 
Join Date: Apr 2009
Posts: 37
Default new light kit not working

I bought a headlight and taillight kit for my 96. I got it installed today and put a lawn battery in (12v). Pulled out on the switch and the relay started clicking but no lights. The relay clicks the entire time the switch is on. Could it be a weak battery or is there another problem? Anybody run into this before? Thanks Brian
tiresmoke216 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-23-2009, 10:29 PM   #2
Gone Wild
 
Tazman00's Avatar
E-Z-GO
 
Join Date: Jun 2008
Location: Bridgeport, MI
Posts: 393
Default Re: new light kit not working

sounds like a dead battery or a bad relay.
Tazman00 is offline   Reply With Quote
Unread 07-24-2009, 01:28 PM   #3
Gone Wild
 
dougmcp's Avatar
 
Join Date: Mar 2009
Location: Roseville, CA
Posts: 2,757
Default Re: new light kit not working

Just checking to make sure you ran the power from the + and - posts on the 12v battery and the wiring, including the relay is not grounded to the frame anywhere.
Other than that, a discharged battery like Tazman00 said is all that's left.
dougmcp is offline   Reply With Quote
Unread 07-25-2009, 08:33 AM   #4
What in the?
 
Hotcat's Avatar
E-Z-GO
 
Join Date: Apr 2009
Location: Lake Worth FL
Posts: 455
Default Re: new light kit not working

When I installed my light kit, the relay was bad straight out the box. Make sure the battery your using is good before anything.
Hotcat is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Got A New Cart Im Working On(help) Gas golf carts
Got a new radio and it's not working - Please help Electric EZGO
2004 e-z go wiring light & rear light Electric EZGO
non working 79 three wheeler Electric EZGO


All times are GMT -5. The time now is 01:19 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.