lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-24-2007, 03:12 PM   #1
Not Yet Wild
 
Join Date: Oct 2007
Posts: 8
Default HELP, electrical problem EZGO

I have an EZ GO, When I put it in forward I take off, when I put it in Reverse it shuts off. I reset the tow switch and off I go. So I can go in forward or reverse, but I can't switch bac and forth... I have to reset the tow/run switch each time I go from one to the other. any help??
glands is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-24-2007, 08:55 PM   #2
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: HELP, electrical problem EZGO

Does it have a F/R handle? is so check the micro switches behind it.
phasetim is offline   Reply With Quote
Unread 10-26-2007, 04:20 PM   #3
Not Yet Wild
 
Join Date: Oct 2007
Posts: 8
Default Re: HELP, electrical problem EZGO

Both switches tested out fine. any other suggestions out there??? I appreciate your help
glands is offline   Reply With Quote
Unread 10-26-2007, 05:43 PM   #4
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: HELP, electrical problem EZGO

What year is the car?
phasetim is offline   Reply With Quote
Unread 10-29-2007, 12:42 PM   #5
Not Yet Wild
 
Join Date: Oct 2007
Posts: 8
Default Re: HELP, electrical problem EZGO

1994.
glands is offline   Reply With Quote
Unread 10-29-2007, 09:51 PM   #6
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: HELP, electrical problem EZGO

there may be a diode/resistor board across the solenoids large post, this board can sometimes cause that symptom as well.
phasetim is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZGO Battery Charger Problem Electric EZGO
1996 Electric Electrical Problem Electric EZGO
charging problem Electric Yamaha
Clutch Problem Gas EZGO
electric ez go problem Electric EZGO


All times are GMT -5. The time now is 05:39 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.