lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 09-20-2009, 11:01 AM   #1
Not Yet Wild
 
Join Date: Aug 2009
Posts: 15
Default 04 EZGO PDS Losing power

Bought an 04 PDs a few weeks back. Every time I run it for about 20 minutes, it dies slowly to the point of stopping. I turn the key off for a minute and turn it back on and I have power for about 20 seconds, then it dies again.( it keeps doing this til I reach home) Batteries are pulling 36v. Just installed new controller last week.(which I thiught was the problem) Anyone have any ideas? Taking this cart to camp in a week for first time and need to get this fixed asap! Thanks in advance.
ta17 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 09-20-2009, 04:42 PM   #2
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: 04 EZGO PDS Losing power

Your controller is toast. I'm assuming that the cart is a lifted PDS?

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 09-20-2009, 04:50 PM   #3
Not Yet Wild
 
Join Date: Aug 2009
Posts: 15
Default Re: 04 EZGO PDS Losing power

yes, its lifted, but it did the same exact thing before it was lifted. Put new controller in last week. (300a)
ta17 is offline   Reply With Quote
Unread 09-20-2009, 05:27 PM   #4
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: 04 EZGO PDS Losing power

Stock controller replacement? You should have installed a 400 amp alltrax

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 09-20-2009, 07:41 PM   #5
Not Yet Wild
 
Join Date: Aug 2009
Posts: 15
Default Re: 04 EZGO PDS Losing power

I dont think its the controller anyways. It did this before I replaced it when the cart wasnt lifted or modified. The problem is still the same.
ta17 is offline   Reply With Quote
Unread 09-21-2009, 12:19 PM   #6
Gone Wild
 
Join Date: Nov 2008
Location: Montgomery, AL
Posts: 1,463
Default Re: 04 EZGO PDS Losing power

Check for power coming out of the solenoid when it quits, if you have power out of solenoid than you controller is going into heat overload.

what size cables are on your cart? 4Ga is recommended. all of them, not just the battery cables, include the ones going to the motor.

BTW -- Lift, big tires and PDS DO NOT go together.
COURTESYCART is offline   Reply With Quote
Unread 09-21-2009, 01:18 PM   #7
Not Yet Wild
 
Join Date: Aug 2009
Posts: 15
Default Re: 04 EZGO PDS Losing power

I didnt know about the lifted pds. I bought the cart and the lift and tires from an ezgo dealer. Never said anything.
ta17 is offline   Reply With Quote
Unread 09-21-2009, 01:20 PM   #8
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: 04 EZGO PDS Losing power

ta17 - What does the dealership that you purchased the cart from say about this problem?

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 09-21-2009, 01:25 PM   #9
Not Yet Wild
 
Join Date: Aug 2009
Posts: 15
Default Re: 04 EZGO PDS Losing power

its a small shop about an hour away. Hes making calls to try to figure it out. Supposed to hear from him today.

I will upgrade the cables no matter what, but like I said, this happened before the lift and tires were installed. Im stumped. (but it doesnt take much to stump me!) Im a newbie cart guy.
ta17 is offline   Reply With Quote
Unread 11-10-2009, 08:46 PM   #10
Not Yet Wild
 
Join Date: Apr 2009
Posts: 30
Default Re: 04 EZGO PDS Losing power

Did you ever figure out the power issue? I have the exact same cart specs with the exact same symtoms. Was going to replace the batteries as they are 4-5 years old. Did your controller get really hot when it would power down?
infospecs is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2004 PDS losing power Electric EZGO
G16 losing connection Gas Yamaha
DS Losing Power Electric Club Car
Engine Losing Power Gas EZGO
Losing power and hard start Gas EZGO


All times are GMT -5. The time now is 07:56 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.