lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-19-2008, 11:48 PM   #11
Not Yet Wild
 
Join Date: Nov 2007
Location: Philippines
Posts: 8
Default Re: troubleshooting electric ezgo

Quote:
Originally Posted by buckmanmike View Post
Most pot boxes work either 0-5k or 5k-0. I've never heard of one to 50k.
Thanks... This is the information that i need to emphasize to him...
cpgolez is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-22-2008, 08:27 PM   #12
Not Yet Wild
 
Join Date: Nov 2007
Location: Philippines
Posts: 8
Default Re: troubleshooting electric ezgo

Thanks for all the help. My cart is finally up and running. This forum sure has been a great help. I was able to finish about 15 holes yesterday. The batteries just probably need more charging.

Cara
cpgolez is offline   Reply With Quote
Unread 07-27-2008, 08:48 PM   #13
Not Yet Wild
 
Join Date: Nov 2007
Location: Philippines
Posts: 8
Default Re: troubleshooting electric ezgo

HI,
After working for about 3 rounds of golf... my cart is back again at its old problem. When I depress the accelerator, there is a click but the cart won't run. What is the problem? i have recently replaced the speed controller and the potentiometer. Could this be a busted controller again?
cpgolez is offline   Reply With Quote
Unread 07-29-2008, 01:07 AM   #14
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2008
Location: Seguin,TX
Posts: 36
Default Re: troubleshooting electric ezgo

Quote:
Originally Posted by cpgolez View Post
HI,
After working for about 3 rounds of golf... my cart is back again at its old problem. When I depress the accelerator, there is a click but the cart won't run. What is the problem? i have recently replaced the speed controller and the potentiometer. Could this be a busted controller again?

Why does a soliniod click like that??? mine does after a while and I assumed it was low Batteries???
turbotexas is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Electric EZGO golf cart wiring diagrams Electric EZGO
Basic Ezgo electric golf cart wiring and manuals Electric EZGO
ezgo electric shuttle Electric EZGO
86 ezgo three wheel electric Electric EZGO
2004 ezgo TXT electric brake issue Electric EZGO


All times are GMT -5. The time now is 05:27 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.