lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-05-2009, 08:29 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2009
Location: Texas
Posts: 7
Default solenoid clicking

I have a 91 electric ez go marathon that I have rebuilt. It was running great until it just stopped. When I push the pedal all it does is make click in the solenoid. I have read other post and they suggest crossing the big terminals on the solenoid and when I did that it still would not run/go.. Any help or suggestions would be greatly appreciated. I will post pic of the project shortly.
dbmw281 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-05-2009, 09:57 PM   #2
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2009
Location: Near Palm Springs Ca
Posts: 34
Default Re: solenoid clicking

did you push on the peddle when you bypassed the solenoid?
AirGuy is offline   Reply With Quote
Unread 10-06-2009, 08:33 AM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2009
Location: Texas
Posts: 7
Default Re: solenoid clicking

Yes, I sure did.
dbmw281 is offline   Reply With Quote
Unread 10-06-2009, 08:37 AM   #4
Carts Unlimited .net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 65,820
Default Re: solenoid clicking

Check all your cable end connections to the motor, F&R, and speed control ?
scottyb is offline   Reply With Quote
Unread 10-06-2009, 09:23 AM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2009
Location: Texas
Posts: 7
Default Re: solenoid clicking

Thanks, I will check this afternoon along with my ohm range on the pot to the controller. I appreciate the quick response.
dbmw281 is offline   Reply With Quote
Unread 10-06-2009, 09:26 AM   #6
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: solenoid clicking

If the wires are ALL good, then you're going to need a volt meter for further questions that you'll be asked

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 10-06-2009, 06:18 PM   #7
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2009
Location: Texas
Posts: 7
Default Re: solenoid clicking

Ok here we go; I cleaned all connections on the motor and F/R and have good readings on the F/R and continuity on the motor from A1 to A2 and S1 to S2. My micro switch which has an orange wire going to the solenoid and a blue one to the controller seams to be working with sending power to the solenoid. I tested the ohms on the speed controller/pot (is the speed controller as some people call it the same as the pot) and it seams to be all over the place. I have a curtis 275A controller and the pot or speed controller under the micro has four wires coming off it with 2 going to the controller and two going to the double micro behind the F/R. If this is what seems to be bad, could i get the pot with the micro switch built in or which pot should i get. I appreciate any help or suggestions from anyone
dbmw281 is offline   Reply With Quote
Unread 10-08-2009, 04:09 PM   #8
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2009
Location: Texas
Posts: 7
Default Re: solenoid clicking

Can anyone help with the below?

Ok here we go; I cleaned all connections on the motor and F/R and have good readings on the F/R and continuity on the motor from A1 to A2 and S1 to S2. My micro switch which has an orange wire going to the solenoid and a blue one to the controller seams to be working with sending power to the solenoid. I tested the ohms on the speed controller/pot (is the speed controller as some people call it the same as the pot) and it seams to be all over the place. I have a curtis 275A controller and the pot or speed controller under the micro has four wires coming off it with 2 going to the controller and two going to the double micro behind the F/R. If this is what seems to be bad, could i get the pot with the micro switch built in or which pot should i get. I appreciate any help or suggestions from anyone
dbmw281 is offline   Reply With Quote
Unread 10-26-2009, 01:33 PM   #9
Not Yet Wild
E-Z-GO
 
Join Date: Oct 2009
Location: Texas
Posts: 7
Default Re: solenoid clicking

Ended up being the controller that was bad.
dbmw281 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Solenoid clicking in low gear??? Electric EZGO
HD solenoid clicking Electric EZGO
solenoid clicking, bad controller? Electric EZGO
clicking Electric EZGO
solenoid clicking Electric Club Car


All times are GMT -5. The time now is 03:39 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.