lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-04-2009, 10:08 PM   #1
Not Yet Wild
 
Join Date: Nov 2009
Posts: 36
Default EZGO charger cuts off before full charge

Model # 26984 Total Charge III. I got this charger used and put an old yellow two prong plug onto the charger as I am using it on our 1975 Cushman (I put this in the EZGO section since I believe it is a charger problem). For awhile the setup worked fine, but eventually the yellow cushman plug started falling apart from age, and then finally I got a bad loose connection that melted it (I could plug it in and wiggle it around and it would stay on and work). During the end of this plug's life I went back once to hear the charger rapidly cycling on and off, and the plug was extremely hot. This is when I decided to bite the bullet and get a new plug.

I ordered anohter plug, installed it, and tried it out. The charger seemed to work fine at first, but now when I plug the charger in, it clicks on for a second or two (meter goes to 20 amps) and the clicks right back off again. Jiggling plug does no good, plug fits tightly into receptacle. I took the cover off of the charger and the MOV 2 Varistor was gone, and one of the wires on the capacitor was loose (touched it and it came loose) and looks like I had some arcing in both places. I reattached the wire to capacitor and no change, although I did plug/unplug the charger a few times tonight and ONCE it stayed on for a few min. When I unplugged/ re-plugged it was back to 1-2 seconds then shuts off.

Batts read 37.7 volts BEFORE I put the pack on a 12V trickle charge for a couple of days (2 at a time) and they were all fairly close in voltage in the low 6's (this was after playing 18 holes twice, while the charger was apparently not staying on long after I left the shed).

Anyone have any suggestions on what this could be?

Thanks!
jeepwm69 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-06-2009, 09:54 AM   #2
Not Yet Wild
 
Join Date: Nov 2009
Posts: 36
Default Re: EZGO charger cuts off before full charge

Bueller.....Bueller................Bueller?
jeepwm69 is offline   Reply With Quote
Unread 11-07-2009, 12:33 PM   #3
Not Yet Wild
 
Join Date: Nov 2009
Posts: 36
Default Re: EZGO charger cuts off before full charge

Ok, this morning to went out and took the plug/ wire off of our EZGO cart, and wired it onto this Total Charge III, then plugged it into the EZGO cart. Same thing. Clicks on for a second or two then clicks back off again. I swapped capacitors from one charger to the other and no change, so I KNOW it's the charger, and I know it's not the capacitor or the fuse. That leaves the control board, diodes, and the transformer. Anyone have any other ideas on what could be causing this? I'd rather not take it to a repair shop, but I'm guessing that's where we will end up with it.
jeepwm69 is offline   Reply With Quote
Unread 11-07-2009, 10:30 PM   #4
Say What ???
 
K9Kev's Avatar
E-Z-GO
 
Join Date: Aug 2008
Location: DFW Texas Baby !!
Posts: 621
Default Re: EZGO charger cuts off before full charge

Hopefully someone here will come along soon and help you out.

.......and WELCOME to BGW

KEV
K9Kev is offline   Reply With Quote
Unread 11-07-2009, 10:32 PM   #5
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: EZGO charger cuts off before full charge

I say take it to a repair shop before you cause any damage...

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 11-07-2009, 10:58 PM   #6
Say What ???
 
K9Kev's Avatar
E-Z-GO
 
Join Date: Aug 2008
Location: DFW Texas Baby !!
Posts: 621
Default Re: EZGO charger cuts off before full charge

What he said ^^^^^.....these things are to $$$ to mess up

Kev
K9Kev is offline   Reply With Quote
Unread 11-13-2009, 09:44 PM   #7
Not Yet Wild
 
Join Date: Nov 2009
Posts: 36
Default Re: EZGO charger cuts off before full charge

Either the relay is bad or the whole board. I bypassed the relay and the charger came on and stayed on until I unplugged the charger. Is this one of those "too good to be true" things? New board, $39 shipped, with warranty?

http://cgi.ebay.com/ebaymotors/ws/eB...K%3AMEWAX%3AIT
jeepwm69 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZGO Textron 36 Volt Battery Charger will not charge Electric EZGO
club car batteries not taking full charge Electric Club Car
93 ez go cuts out at near full throttle Electric EZGO
G16 Cuts Out If Not 3/4 Or Full Throttle Gas Yamaha
Charger cuts off after 5 mins? Electric Club Car


All times are GMT -5. The time now is 02:08 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.