lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-17-2009, 04:43 PM   #1
Not Yet Wild
 
Join Date: Dec 2009
Posts: 20
Default Positive Battery terminal Sparks when I press the Accelerator

I have a 2003 ez-go golf cart with the tow/run switch. I have tried the diagnostic beep test and got no diagnostic beeps back. When I push down the accelerator, the positive terminal on the battery that goes straight to the controller starts sparking right where the cable connects to the terminal. It's melting the end of the cable where the connector is and I can't drive my cart. :(
Any help would be greatly appreciated.
Thank you!
think92 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-17-2009, 04:45 PM   #2
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Positive Battery terminal Sparks when I press the Accelerator

Sounds like a bad connection...

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 12-17-2009, 04:57 PM   #3
Not Yet Wild
 
Join Date: Dec 2009
Posts: 20
Default Re: Positive Battery terminal Sparks when I press the Accelerator

Bad connection to what? All of my battery cables were just replaced with a heavy guage welding wire. all wires to and from the batteries are very tight. I think i noticed when I push the accelerator down a lot I get a BIG spark, if I push it a little bit, it has a smaller spark... does that help?
think92 is offline   Reply With Quote
Unread 12-17-2009, 05:00 PM   #4
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Positive Battery terminal Sparks when I press the Accelerator

Are you sure your cable is properly crimped? Is this a set of cables someone made or are they a manufactured set?

A spark will come from a loose connection...

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 12-17-2009, 05:06 PM   #5
Not Yet Wild
 
Join Date: Dec 2009
Posts: 20
Default Re: Positive Battery terminal Sparks when I press the Accelerator

yea, it was working just fine with the cables that are on there for a couple of months until one day it just started doing this. I just went out there again and looked at it again and I noticed it does not move either when I push the Accelerator.
The cables were professionally made in a machine shop... things cost me 120$... grrr

Could this be something to do with the speed controller or something? Since it's a big spark when pedal fully pressed and little/no spark when pedal barely pushed??
think92 is offline   Reply With Quote
Unread 12-17-2009, 05:11 PM   #6
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Positive Battery terminal Sparks when I press the Accelerator

Where exactly does the spark come from? Battery terminal post? Cable lug where is joins the cable?

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 12-17-2009, 05:23 PM   #7
Not Yet Wild
 
Join Date: Dec 2009
Posts: 20
Default Re: Positive Battery terminal Sparks when I press the Accelerator

well where the cable connects to the post the rubber at the end of it is getting melted. So I think it's coming from right at the end of the cable very close to the + post.
it doesn't spark or anything when it's just sitting there either...
think92 is offline   Reply With Quote
Unread 12-17-2009, 05:25 PM   #8
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Positive Battery terminal Sparks when I press the Accelerator

As a precaution - take the cable off and try to re-crimp it with some vice grips. Look it over really well before and see if it seems loose inside.

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 12-17-2009, 05:42 PM   #9
What was I thinking?
 
sak00's Avatar
Mixed Breed
 
Join Date: Jul 2009
Location: Brooksville, Florida
Posts: 577
Default Re: Positive Battery terminal Sparks when I press the Accelerator

Sounds like a bad crimp job on the cable end to me.
sak00 is offline   Reply With Quote
Unread 12-17-2009, 05:42 PM   #10
Not Yet Wild
 
Join Date: Dec 2009
Posts: 20
Default Re: Positive Battery terminal Sparks when I press the Accelerator

I just pulled it off and checked it out all the wiring is fine still, just the heat wrap has melted a little on the bottom but the connections are VERY tight. I did squeeze it with some vice grips though and still I could not get it any tighter...

All the cables are only a couple months old, which is weird cause the cables before were practically falling off just hanging by seriously a thread and I never had a problem like this...
think92 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
MELTED... Battery Terminal Electric Club Car
Tapping a New Battery Terminal Electric EZGO
Battery terminal broke Electric EZGO
black battery terminal Electric EZGO
battery terminal Electric Club Car


All times are GMT -5. The time now is 01:33 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.