lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-15-2007, 09:57 AM   #11
roady89
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by fastjim11
Its a Textron Ez-Go charger. It hums when turned on.

Jim
It wont put out much voltage until its plugged in. Check it when plugged into the cart. Its not supposed to kick on unless its plugged in...so you have a problem there. It will more than likely be the PC board inside the charger. It will still charge but it probly wont shut off so you will have to watch it till you get it fixed. Andy has done lots of repairs to chargers also so he might know a trick or 2.
  Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-15-2007, 10:08 AM   #12
Gone Wild
 
Join Date: Dec 2006
Posts: 381
Default

This charger is old. It only has a coil, a timer, a capasitor, and I think a heat sink (a large alum. plate with wires going to it)
And thats it.
fastjim11 is offline   Reply With Quote
Unread 01-15-2007, 10:11 AM   #13
Gone Wild
 
Join Date: Dec 2006
Posts: 381
Default

Oh yeah, its probably the original charger that came with the cart in 1974. No pc board...... Straight up plain ole electric. I could measure coil values and such if I knew the specs. since thats about all that could be bad.
fastjim11 is offline   Reply With Quote
Unread 01-15-2007, 10:13 AM   #14
roady89
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by fastjim11
This charger is old. It only has a coil, a timer, a capasitor, and I think a heat sink (a large alum. plate with wires going to it)
And thats it.
Any pics? I still dont think it should kick on even though its old.
  Reply With Quote
Unread 01-15-2007, 10:15 AM   #15
Gone Wild
 
Join Date: Dec 2006
Posts: 381
Default

I go make some right now.
fastjim11 is offline   Reply With Quote
Unread 01-15-2007, 10:22 AM   #16
Gone Wild
 
Join Date: Dec 2006
Posts: 381
Default

hey where's the pic upload button
fastjim11 is offline   Reply With Quote
Unread 01-15-2007, 10:23 AM   #17
roady89
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by fastjim11
hey where's the pic upload button
Hold on..lemme look...its there..right under the Img and URL bottons
  Reply With Quote
Unread 01-15-2007, 10:27 AM   #18
Gone Wild
 
Join Date: Dec 2006
Posts: 381
Default

mine just says close tags what tha...
fastjim11 is offline   Reply With Quote
Unread 01-15-2007, 10:32 AM   #19
Gone Wild
 
Join Date: Dec 2006
Posts: 381
Default

aha...got it! Couldn't see it in acid green!


fastjim11 is offline   Reply With Quote
Unread 01-15-2007, 10:34 AM   #20
roady89
Guest
 
Posts: n/a
Default

Quote:
Originally Posted by fastjim11
aha...got it! Couldn't see it in acid green!
Ok...sorry to get off topic but I will have to make the mods to the acid green templates....Sorry about that.
Yes...umm....that is quite old.
  Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 09:01 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.