lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-19-2010, 01:32 PM   #1
Not Yet Wild
 
roxter32's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: austin,tx
Posts: 12
Default Golf Cart Lost Power

Okay, so I have a 2005 EZ GO PDS with an Alltrax DCX 400, heavy duty solenoid and a 1 year old D&D motor. The cart has a Jake's lift and a backseat with oversized tires. It does a lot of climbing of hills in my lakeside neighborhood so I dialed the controller in for more torque.

Last week I had 3 others on the cart and it suddenly couldn't even back out of a small driveway with a insignificant incline. I had the cart serviced this week...oil in the rear gearbox, water, greased, etc... and when I drove it today it still has lost significant power.

Any ideas of what the issue could be?
roxter32 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-19-2010, 02:02 PM   #2
Not Yet Wild
 
roxter32's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: austin,tx
Posts: 12
Default Re: Golf Cart Lost Power

Also, have'nt been on the cart in about 45 minutes but the motor is still very, very hot to touch.
roxter32 is offline   Reply With Quote
Unread 06-19-2010, 02:15 PM   #3
Gone Wild
 
rabbitreborn's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Central Florida
Posts: 2,704
Default Re: Golf Cart Lost Power

possibility of a short in the motor? Have you plugged into the controller to see what it is saying?
rabbitreborn is offline   Reply With Quote
Unread 06-19-2010, 02:18 PM   #4
Gone Wild
 
dougmcp's Avatar
 
Join Date: Mar 2009
Location: Roseville, CA
Posts: 2,757
Default Re: Golf Cart Lost Power

Make sure your batteries are charged, you have at least 38.2v after a charge and rest.
Loading the cart up with a full load and large tires may have sent the controller into limp mode. Do you have any codes flashing?
Check all your battery connections for clean and tight condition.
A motor, too hot to touch is not uncommon after cruising.
dougmcp is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Lost power Electric Club Car
Lost Power Electric EZGO
helpppp lost power backfired and now its not turning over Gas Yamaha
upgrading wiring-lost power Electric EZGO
Club car lost power on impact to differential Electric Club Car


All times are GMT -5. The time now is 09:12 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.