lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-21-2008, 09:06 PM   #1
Not Yet Wild
 
Join Date: Feb 2008
Posts: 2
Default 1991 EZGo Electric: Reverse Doesn't Work?

Hi everyone - I'm new to the forum and hope I am in the right spot, asking the right questions. I have a 1991 EZGo electric golf cart. Several months ago, reverse gear quit working most of the time, although occasionally it would work. Forward gear works fine. Thought it might be a dirty contact of some kind, but no. Replaced the gear selection box (right behind the gear selector) and also replaced a suspicious looking heavy gauge wire from the gear selecter box. Still no reverse. Now I hear a clicking noise like the solenied operating when it's in reverse and I step on the accelerator. What should I try now? Boxes on the driveline in the battery compartment (relays, maybe)? Something in the motor? Any other ideas would be appreciated! Thanks.
shcram is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-21-2008, 09:22 PM   #2
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,913
Default Re: 1991 EZGo Electric: Reverse Doesn't Work?

Sounds like the contacts on the Forward/reverse switch. Have you checked them? If you can get it apart you can take a fine file and file the contacts flat to take out the rough spots and get some more use out of them. They are easily replaced and also fairly cheap new. It could possibly be a micro switch on the F/R switch.


It wont be anything in the motor or solenoid.
roady89 is offline   Reply With Quote
Unread 02-22-2008, 02:33 PM   #3
72 volts!
 
Andy4639's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Liberty SC, Garden City SC
Posts: 5,412
Default Re: 1991 EZGo Electric: Reverse Doesn't Work?

Where the cables attach to the F/R switch tug on them and see if any of them move. If so then remove and clean them good. Also check the studs. Loose connections are the first signs of heat.
Check the reverse micro switch. Make sure it's riding the cam that activates it.
Andy4639 is offline   Reply With Quote
Unread 02-22-2008, 08:11 PM   #4
Not Yet Wild
 
Join Date: Feb 2008
Posts: 2
Default Re: 1991 EZGo Electric: Reverse Doesn't Work?

Thanks for the suggestions, Andy4639 and roady89. I have cleaned the contacts already, but that was a good suggestion. Can someone tell me where the reverse microswitch is, and where the cam is that it is supposed to ride on? How do I get to it to check it - and is it better to just replace the microswitch once I find it? Thanks again for the help!
shcram is offline   Reply With Quote
Unread 02-22-2008, 10:15 PM   #5
72 volts!
 
Andy4639's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Liberty SC, Garden City SC
Posts: 5,412
Default Re: 1991 EZGo Electric: Reverse Doesn't Work?

The micro's are on the backside of the F/R switch. They are mounted to it. The cam is the round part the micro switch wheel rolls on when you turn the handle.
Andy4639 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1991 ezgo marathon manual Electric EZGO
1994 Ezgo electric runs great in reverse but does not forward Electric EZGO
80 electric ezgo with no reverse Electric EZGO
Mid 90 EZGO will reverse but not go forward Electric EZGO
1991 CLUB CAR Gas Club Car


All times are GMT -5. The time now is 02:54 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.