lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-26-2010, 06:24 PM   #21
Gone Wild
 
athomas03's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: So GA
Posts: 237
Default Re: 400 or 500 amp?

Cool, let us know what you think after you try it out.
athomas03 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-26-2010, 06:32 PM   #22
Gone Wild
 
dougmcp's Avatar
 
Join Date: Mar 2009
Location: Roseville, CA
Posts: 2,757
Default Re: 400 or 500 amp?

I would leave it in the "out of the box" mode and run it for awhile before you start changing the parameters. This way you have something to gauge your adjustments on. Also, make note of the factory settings so you can return to them if necessary.
dougmcp is offline   Reply With Quote
Unread 08-26-2010, 06:55 PM   #23
Gone Wild
 
rxp-rider's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: CLEARWATER,FL.
Posts: 555
Default Re: 400 or 500 amp?

THANKS ,THAT'S WHAT I'LL DO
rxp-rider is offline   Reply With Quote
Unread 08-27-2010, 05:59 PM   #24
Gone Wild
 
rxp-rider's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: CLEARWATER,FL.
Posts: 555
Default Re: 400 or 500 amp?

Will the alltrax bolt right in place of my stock one or will i need to drill new holes into the heat sink? It can't get here fast enough !!
rxp-rider is offline   Reply With Quote
Unread 08-27-2010, 07:31 PM   #25
Gone Wild
 
rabbitreborn's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Central Florida
Posts: 2,704
Default Re: 400 or 500 amp?

did you get the long body or the short body controller? The short body should bolt right up with no problems.
rabbitreborn is offline   Reply With Quote
Unread 08-27-2010, 08:30 PM   #26
Gone Wild
 
rxp-rider's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: CLEARWATER,FL.
Posts: 555
Default Re: 400 or 500 amp?

SHORT BODY
rxp-rider is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 05:07 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.