lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 10-07-2010, 09:08 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2010
Location: Fort Worth, Texas
Posts: 18
Default Someone double check me PLEASE

Good Evening Gents.

I am installing a new alltrax 400 amp controler as i type this. It is on my 1996 EZ GO TXT, 36 Volt, new T-105 batteries, new 400 amp contactor with upgraded diode and res., all wiring has been replaced with 2ga.. The controler is an Alltrax AXE400. I have the 250 amp fuse mounted on one of the batteries. Just trying to see if i have forgotten anything before i hook the batteries up and test.

Also, do i need to program the controler before i power everything up?

Any help would be great.

Thanks
Michael
817michaelj is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 10-07-2010, 09:10 PM   #2
Carts Unlimited .net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 65,790
Default Re: Someone double check me PLEASE

No, the factory default settings are good enough ... until you think you want to change something. Resistor and diode should be same rating as stock ..... they are voltage specific. Not changing with higher amperage
scottyb is offline   Reply With Quote
Unread 10-07-2010, 09:11 PM   #3
??????
 
LostHusker's Avatar
E-Z-GO
 
Join Date: Sep 2009
Location: South TX
Posts: 8,585
Default Re: Someone double check me PLEASE

Quote:
Originally Posted by 817michaelj View Post
Good Evening Gents.

I am installing a new alltrax 400 amp controler as i type this. It is on my 1996 EZ GO TXT, 36 Volt, new T-105 batteries, new 400 amp contactor with upgraded diode and res., all wiring has been replaced with 2ga.. The controler is an Alltrax AXE400. I have the 250 amp fuse mounted on one of the batteries. Just trying to see if i have forgotten anything before i hook the batteries up and test.

Also, do i need to program the controler before i power everything up?

Any help would be great.

Thanks
Michael
Did you follow the wiring diagram from Alltrax, if so then double check your connections again, make sure they are tight,,,,,,and if your ready then turn the key switch to see if the controller turns on. You can program the controller this way, or find an alternate source to power it up, it needs at least 12v to power up for programming.
LostHusker is offline   Reply With Quote
Unread 10-07-2010, 09:20 PM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2010
Location: Fort Worth, Texas
Posts: 18
Default Re: Someone double check me PLEASE

Thanks alot guys, I am rechecking all the wiring now to make sure everything is in the right location and tight. I forgot to say that the FnR switch is upgraded also. I guess next thing is a high speed motor.
817michaelj is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G9 check fuel pump check valve? Gas Yamaha
Double D's G-2 build Members Rides
single or double Lifted Golf Carts
1992 G9 Double A Arm lift Gas Yamaha
Double Lift? Design Center


All times are GMT -5. The time now is 08:57 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.