lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-12-2010, 11:00 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2010
Location: Exmore
Posts: 7
Default Charging / Battery / Charger trouble?

I have a 48 volt EZGO that I bought used a few months back. This is my first cart and first experience with a charger. The guy I bought it from said leave it on the charger at all times when not using the cart, and I do.

When I finished riding the cart this past Sunday, I did not plug it in right away, instead I waited one day. Monday when I hooked up the charger I noticed the amp gauge did not move, but I heard the fan inside the charger power up like normal.

Normally after its been on charge for a while the fan will cycle on and off, but not this time. The fan has remained on for 5 days and the amp gauge on the charger is not moving. I have tried to unplug the cart from the charger to see if anything changes but it hasn't.

I let it run again last night and when I just checked it the fan is running and the gauge on the charger is on zero.

I do not have a charge meter on the cart to see if power is going to the cart. This could be normal and I am just not aware. Any help or insight would helpful.
esvadj is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-12-2010, 11:12 AM   #2
You did what !?
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,848
Default Re: Charging / Battery / Charger trouble?

Since you have no tools ..... drive the cart and see if it seems to have recharged?

In the future, recharge your cart immediately after use.
It is bad for the batteries to be depleted and left to sit.
If the cart is not okay we will need a voltmeter reading to determine the pack voltage. The charger needs to see a minimum # of volts to turn on. You may be below that minimum.
scottyb is online now   Reply With Quote
Unread 11-13-2010, 09:07 AM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2010
Location: Exmore
Posts: 7
Default Re: Charging / Battery / Charger trouble?

The cart seems charged, I took it out last night and rode around for about 20 minutes.

I hooked it back to the charger and the same thing is happening. What should the amp meter be reading? I have a multi-meter, how would I go about checking the pack charge?

Thanks
esvadj is offline   Reply With Quote
Unread 11-13-2010, 09:39 AM   #4
You did what !?
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,848
Default Re: Charging / Battery / Charger trouble?

Set the DVM to 200 VDC.
Check VDC at the charger port.
scottyb is online now   Reply With Quote
Unread 11-13-2010, 12:20 PM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2010
Location: Exmore
Posts: 7
Default Re: Charging / Battery / Charger trouble?

49.6 at the charger port. Does this mean something is wrong with the charger?
esvadj is offline   Reply With Quote
Unread 11-13-2010, 12:27 PM   #6
You did what !?
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,848
Default Re: Charging / Battery / Charger trouble?

It is inconclusive. It only means the batteries are not fully charged. Let the charger run and see if it will bring the pack up to 58-63 v. You may have a battery problem if they will not come up to enough voltage to auto shut off the charger.
scottyb is online now   Reply With Quote
Unread 11-13-2010, 05:34 PM   #7
Not Yet Wild
E-Z-GO
 
Join Date: Sep 2010
Location: Exmore
Posts: 7
Default Re: Charging / Battery / Charger trouble?

I think I figured out the problem, one of the terminals on the charger side of the plug has broke.

When I went to put it back on the charger after the previous post, it worked fine. I took it out for a spin, then hooked it back to the charger and was having trouble again.

Are end available for these cords? I see screw holes in the end so it must come apart.

Thanks for all your help in this matter.
JD
esvadj is offline   Reply With Quote
Unread 11-13-2010, 05:59 PM   #8
You did what !?
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 64,848
Default Re: Charging / Battery / Charger trouble?

Does it look like this?
Attached Images
File Type: jpg IMG_3541.jpg (76.6 KB, 7 views)
scottyb is online now   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
1990 club car 36 volt battery trouble Electric Club Car
Charging 8v battery with 12 volt charger? Electric Club Car
2004 Club Car Precedent battery trouble Electric Club Car
96 36 volt charging trouble Electric EZGO
Charging a 36v with a 12v charger? Electric Club Car


All times are GMT -5. The time now is 09:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.