lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 11-30-2010, 06:07 PM   #1
Not Yet Wild
 
Join Date: Feb 2009
Posts: 7
Default Battery Charger Question

I just replaced all 6 batteries in my 2005 EZ-GO TXT. I have had them for about 1 month and now my charger flashes red twice as soon as I plug it in then a pause. I think the fault means the batteries are too low to charge or they are over charged. What should I do to check this fault? In addition, if they are over charged is this bad for the batteries and what should I do? BTW, I use the cart most every day and plug it in every day. Thanks for any and all help.



golfunguy
golfunguy is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 11-30-2010, 06:56 PM   #2
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Battery Charger Question

What is your battery voltage? Check it with your volt meter and you may be able to answer your own question! Has the cart been running? Do you have any accessories wired to the battery pack causing a draw? Delta chargers require 27 volts to turn on...

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 12-01-2010, 06:42 PM   #3
Not Yet Wild
 
Join Date: Feb 2009
Posts: 7
Default Re: Battery Charger Question

Thanks for the reply. I borrowed another EZ-GO charger today and that charger is operating properly, so something is wrong with my charger.

Thanks again.
golfunguy
golfunguy is offline   Reply With Quote
Unread 12-10-2010, 04:56 PM   #4
Not Yet Wild
 
Join Date: Dec 2010
Posts: 11
Default Re: Battery Charger Question

My ezgo 2005 power wise charger does not shut off automaticlly
radiator is offline   Reply With Quote
Unread 12-10-2010, 05:04 PM   #5
Carts Unlimited .net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 65,398
Default Re: Battery Charger Question

Likely you have one or more bad batteries in your pack .... what is the highest voltage reading you get on the battery Pack while it is charging.......
scottyb is offline   Reply With Quote
Unread 12-10-2010, 09:51 PM   #6
Not Yet Wild
 
Join Date: Dec 2010
Posts: 11
Default Re: Battery Charger Question

Thank you for your quick reply,I just installed all new batterys
radiator is offline   Reply With Quote
Unread 12-10-2010, 09:58 PM   #7
Carts Unlimited .net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 65,398
Default Re: Battery Charger Question

Please start your own thread so we can better solve your problem. Get a voltmeter and prepare to post pack and individual readings. You may have the pack wired incorrectly please start your own thread if you need more help.
scottyb is offline   Reply With Quote
Unread 12-11-2010, 10:34 PM   #8
Gone Wild
 
arcitech's Avatar
E-Z-GO
 
Join Date: Mar 2010
Location: Hampton, VA
Posts: 503
Default Re: Battery Charger Question

Quote:
Originally Posted by golfunguy View Post
Thanks for the reply. I borrowed another EZ-GO charger today and that charger is operating properly, so something is wrong with my charger.

Thanks again.
golfunguy
Yep! Seems to be the problem. Now how about a solution, anybody got some Powerwize info to help out??? Can you give us the model number or any other info? It could be an easy fix or it might need a little more help, but I'm sure it can be fixed.
arcitech is offline   Reply With Quote
Unread 12-12-2010, 08:38 AM   #9
Not Yet Wild
 
Join Date: Aug 2010
Posts: 2
Default Re: Battery Charger Question

Just FYI, DO NOT mess with LVS Chargers as i learned my lesson:
From diferent people:

From what I have read, LVS does not have a good rep for customer service, have you tried calling them to have your unit repaired?
Their contact info is:
LVS Sales
7281 NW 77th Street
Miami, FL 33166
Tel 1-305-889-3464[/quote]
IF that aint the TRUTH.. We ordered a board that is still shown on there web site for my LVS 3648 charger, They L.S. (LVS manager)sent the wrong board. We called immediatley(there mistake) they said send it back. Then they say they can't get that board anymore & they will credit our acct. This took 2.5 months to try & get our money back, & all this was there mistake & I had to pay shipping each way.... I HIGHLY tell anyone, DO NOT go through the LIES & FRUSTRATION as we did of messing with this comapany!!!!!!!!
cajunboyz is offline   Reply With Quote
Unread 12-12-2010, 05:57 PM   #10
Not Yet Wild
 
Join Date: Dec 2010
Posts: 11
Default Re: Battery Charger Question

I just tried myneibours charger and it shut off. I had my charger on for 4 hrs. and it read 3 points off of zero maybe I will try mine again but leave it on longer
radiator is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Battery charger question Electric EZGO
BAttery Charger Question Electric EZGO
Battery Charger Question Electric EZGO
Battery charger question. Electric EZGO
Another Battery / Charger Question Electric Club Car


All times are GMT -5. The time now is 05:52 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.