lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 02-26-2011, 10:23 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2008
Location: Georgia
Posts: 4
Default 93 ez go that won't go

1st post. 93 ez go that was running fine. Backed it out of the garage and it stopped running. Would lurch a iinch or two at a time. Disconnected for 12 hours after full charge showing 37.7 volts (6.28, 6,28, 6.34, 6.34, 6.33, 6.35). Checked the solenoid and it checked out fine. Any other words of wisdom, guidance etc...
sliverman73 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 02-26-2011, 10:31 AM   #2
Not Yet Wild
 
Join Date: Jan 2011
Posts: 53
Default Re: 93 ez go that won't go

Sounds like a loose connection somewhere. I would start by tugging on all the connections and make sure they are tight.
ron67601 is offline   Reply With Quote
Unread 02-26-2011, 11:03 AM   #3
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 63,802
Default Re: 93 ez go that won't go

After you check that all your cable connections are tight and clean, Connect the meter to the pack and try to go... does the voltage drop? Are you hearing the solenoid click when you try to go?
scottyb is offline   Reply With Quote
Unread 02-26-2011, 11:25 AM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2008
Location: Georgia
Posts: 4
Default Re: 93 ez go that won't go

thanks. solenoid clicks. voltage drop. connections tight.
sliverman73 is offline   Reply With Quote
Unread 02-26-2011, 11:31 AM   #5
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 63,802
Default Re: 93 ez go that won't go

Voltage drop from what to what reading?
scottyb is offline   Reply With Quote
Unread 02-26-2011, 12:09 PM   #6
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2008
Location: Georgia
Posts: 4
Default Re: 93 ez go that won't go

37.4 to 35 then voltages rises and pegs out meter???
sliverman73 is offline   Reply With Quote
Unread 02-26-2011, 12:41 PM   #7
Cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 63,802
Default Re: 93 ez go that won't go

What is the meter set to?
scottyb is offline   Reply With Quote
Unread 02-26-2011, 01:20 PM   #8
Not Yet Wild
E-Z-GO
 
Join Date: Jul 2008
Location: Georgia
Posts: 4
Default Re: 93 ez go that won't go

200 DCV. Initial shows 37.4 drops to 32.2 and then progressively rises.
sliverman73 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 11:04 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.