lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 04-17-2011, 11:52 AM   #1
Not Yet Wild
 
Join Date: Apr 2011
Posts: 5
Question 81 EZ Go Charger - Turns on but reads 0 amps

Hi all!

I am a newbie to all of this. In the last couple of weeks I have been restoring a cart for fun. I noticed last night that when I connect the charger and turn it on it will turn on but it just hums and the amp meter reads 0 on the charger. If I turn it on and off a couple times real fast the need jumps back and forth. The guage goes up to 30.

Can anyone tell me what the problem may be. I hopen I don't have a bad charger. I put the key in last night and turned it on and it appears to still have enough charge to backup and go forward.

Any help would be appreciated. Thanks!

Calvin
Calvin_Moser31 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 04-17-2011, 12:23 PM   #2
Gone Wild
E-Z-GO
 
Join Date: Feb 2011
Location: Florida USA
Posts: 162
Default Re: 81 EZ Go Charger - Turns on but reads 0 amps

I have seen the capacitor go bad in these chargers but in that case they don't charge just hum. (needle on zero as well).

There is also a fuse in there too you could check.

Find out if it charges or not. Hopefully others will help you.
72volt_ezgo is offline   Reply With Quote
Unread 04-17-2011, 02:33 PM   #3
Not Yet Wild
 
Join Date: Apr 2011
Posts: 5
Default Re: 81 EZ Go Charger - Turns on but reads 0 amps

I think I figured out problem and had turn learn the hard way. I was messing witht he charger and got it to charge for like 10 seconds. It then went back to 0. I then turned off and back on and noticed there was a spark on the battery where the charges port hooks to. I noticed the wires were lose, so me being a dummy tried to take the nut of the top and broke off the post! I guess I will get a new battery and replace it, and clean the cables, hopefully that will also make the charger work.

Any suggestions on replacements? I know I have read that adding a new battery to the mix is not a good idea but I don't have the money to buy all 6 new.

Can the Trojan T105 be replaced with a replacement of another cheaper brand?

Thanks all.
Calvin_Moser31 is offline   Reply With Quote
Unread 04-17-2011, 03:35 PM   #4
Carts Unlimited .net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 65,689
Default Re: 81 EZ Go Charger - Turns on but reads 0 amps

Roady's battery terminal Repair:
http://www.buggiesgonewild.com/batte...nal-repair.php
scottyb is offline   Reply With Quote
Unread 04-17-2011, 08:51 PM   #5
Gone Wild
 
Join Date: Dec 2010
Location: West Texas
Posts: 182
Default Re: 81 EZ Go Charger - Turns on but reads 0 amps

Good information.

Thank you for posting
HGC2010 is offline   Reply With Quote
Unread 04-17-2011, 08:52 PM   #6
Not Yet Wild
 
Join Date: Apr 2011
Posts: 5
Default Re: 81 EZ Go Charger - Turns on but reads 0 amps

Thanks for the input. Here is a pic, do you think this can be saved by doing the repair? This thing completely broke off.
Attached Images
File Type: jpg battery.jpg (61.4 KB, 13 views)
Calvin_Moser31 is offline   Reply With Quote
Unread 09-18-2011, 04:04 AM   #7
Not Yet Wild
 
turblown's Avatar
E-Z-GO
 
Join Date: Oct 2010
Location: Buckeye, AZ
Posts: 74
Default Re: 81 EZ Go Charger - Turns on but reads 0 amps

Any updates on the status of the charger?
turblown is offline   Reply With Quote
Unread 09-18-2011, 03:45 PM   #8
Not Yet Wild
 
Join Date: Apr 2011
Posts: 5
Default Re: 81 EZ Go Charger - Turns on but reads 0 amps

After I replaced the battery I broke and cleaned the connections the charger then worked. I used the cart for half the summer and then sold it.
Calvin_Moser31 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
charger reads, check batteries, and limit use with new batteries! Electric Club Car
48v charger hums but amps read 0 Electric Club Car
99 Club Car Charger won't go below 10 amps Electric golf carts
charger hangs on 2 amps Electric Club Car
correct charger amps? Electric golf carts


All times are GMT -5. The time now is 07:04 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.