lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-02-2008, 11:20 AM   #1
Not Yet Wild
 
Join Date: Apr 2008
Location: Have a home in Delaware and Snow bird in FL
Posts: 9
Default Cart does not run at advertised speed

2007 EZ GO Freedom Model was advertised to run 19.5 MPH with the new all track. Also have replaced 8" tires with 10" tires. Cart still only runs max 18.5 MPH and does not maintain that speed. Has anybody experienced this probem and if so what was the fix? Also what else could be done to gain more speed.
fredt28 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-03-2008, 02:54 AM   #2
Gone Wild
 
buckmanmike's Avatar
 
Join Date: Oct 2007
Location: Snellville, Ga.
Posts: 1,062
Default Re: Cart does not run at advertised speed

If it doesn't meet advertised claims, take it back to dealer.
buckmanmike is offline   Reply With Quote
Unread 05-03-2008, 06:35 AM   #3
Not Yet Wild
 
Join Date: Apr 2008
Location: Have a home in Delaware and Snow bird in FL
Posts: 9
Default Re: Cart does not run at advertised speed

Thanks for the reply. The cart has been back to the dealer at least 2 times. The motor was replaced once. The dealer has no other answers to this problem.
fredt28 is offline   Reply With Quote
Unread 05-03-2008, 11:34 AM   #4
72 volts!
 
Andy4639's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Liberty SC, Garden City SC
Posts: 5,412
Default Re: Cart does not run at advertised speed

What do you mean by doesn't maintain speed? If it goes into coasting at max speed it's got the all terrain chip in it. You need the red wire chip in it to get max speed.
Andy4639 is offline   Reply With Quote
Unread 05-03-2008, 01:28 PM   #5
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: Cart does not run at advertised speed

Is it a Freedom TXT or Freedom PDS? Where is the F/R switch?

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 05-06-2008, 03:34 AM   #6
Not Yet Wild
 
Join Date: Apr 2008
Location: Have a home in Delaware and Snow bird in FL
Posts: 9
Default Re: Cart does not run at advertised speed

Sorry for the delay in responding, the cart in question belongs to a friend and it took some time to get this information.

The Forward and Reverse switch is located on the dash. You mentioned that it should be the red wire for the fastest speed. Where would I look to find out what chip is in the cart.
fredt28 is offline   Reply With Quote
Unread 05-06-2008, 06:41 AM   #7
Not Yet Wild
 
Join Date: Apr 2008
Location: Have a home in Delaware and Snow bird in FL
Posts: 9
Default Re: Cart does not run at advertised speed

Quote:
Originally Posted by Andy4639 View Post
What do you mean by doesn't maintain speed? If it goes into coasting at max speed it's got the all terrain chip in it. You need the red wire chip in it to get max speed.
Thanks for the response, sorry it took so long to respond. Could you tell me where to find the chip? The cart does not maintain a constant speed while driving on a level ground.
fredt28 is offline   Reply With Quote
Unread 05-06-2008, 09:09 AM   #8
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,913
Default Re: Cart does not run at advertised speed

Quote:
Originally Posted by fredt28 View Post
Thanks for the response, sorry it took so long to respond. Could you tell me where to find the chip? The cart does not maintain a constant speed while driving on a level ground.

Look at this topic. 10th picture down you will see the "chip". Its not really a chip. Its a plug.
Basic Ezgo electric golf cart wiring and manuals
roady89 is online now   Reply With Quote
Unread 05-07-2008, 02:28 PM   #9
Not Yet Wild
 
Join Date: Apr 2008
Location: Have a home in Delaware and Snow bird in FL
Posts: 9
Default Re: Cart does not run at advertised speed

Thanks for the info. I opened the wiring manual this am and it worked fine. Attempted to open again this PM and the picture of the chip diagram would not open. Could you resend just the chip diagram?

Thanks
Fred
fredt28 is offline   Reply With Quote
Unread 05-07-2008, 07:23 PM   #10
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 25,037
Default Re: Cart does not run at advertised speed

Try this:
http://img338.imageshack.us/img338/6043/pds1tn0.jpg
gornoman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Melex 36 Volt Cart only goes at slow speed Melex
EMP 2 speed golf cart motors Golf Cart Parts
Super Speed Your Cart..... Gas Club Car
High Speed cart gears Gas Club Car
Ezgo speed cart for sale Golf Carts and Parts


All times are GMT -5. The time now is 07:21 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.