lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-12-2008, 12:23 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2008
Location: Baton Rouge, La.
Posts: 4
Angry First time cart owner and after 2 months, it stopped working!

Hello guys and girls, I bought an EZ-GO golf cart 2 months ago and the other day all it did was clicked-clicked, smelled a little burning, pulled seat up and did it again at night and it was arcing/sparking when you pressed on the go pedal. I took pictures the next day from where it was coming from (minus the cover). It still beeps when you put it in reverse, batteries are strong, it's full charhed but just won't go, forward or backwards. Another thing, can someone tell me what year my cart is? It has a manufacturers code of L402. My daughters are really missing the cart. Any help would be greatly appreciated. I have attached 2 pics, if it helps anyone.

Thank you,
Dave
Attached Images
File Type: jpg golfcart1.JPG (85.7 KB, 44 views)
File Type: jpg golfcart.jpg (50.9 KB, 37 views)
notredave is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-12-2008, 09:04 PM   #2
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: First time cart owner and after 2 months, it stopped working!

Welcome notredave..................

Looks like your cart is a 2002 year model.

Check all connections on top of the batteries for tightness. If you pull or yank on the cables they should NOT turn or slip around the posts.

The area shown just under the passenger seat is as follows:

The device on the right is the Forward & Reverse switch......
(where the cover is missing)

The device on the left is the controller.........

Check the wires for fray and loosness.

Always remember...... When working on the electrical system, disconnect the main Positive and Main Negative of the battery pack. This will keep you from trashing a good comtroller.

There are plenty of guys on here who are here to offer help.
Roady 89 is good with these carts.
rusty is offline   Reply With Quote
Unread 05-12-2008, 09:48 PM   #3
Not Yet Wild
Yamaha
 
Join Date: May 2008
Location: Northern Michigan
Posts: 29
Default Re: First time cart owner and after 2 months, it stopped working!

I think I would start by cleaning up the conections and make sure that everything is tight. Loose conection , expecially ground wires, can cause caos.
racinghauler is offline   Reply With Quote
Unread 05-12-2008, 10:03 PM   #4
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: First time cart owner and after 2 months, it stopped working!

The arcing is coming from your F/R switch. Sounds like your F/R switch is either going out or gone out. If the contacts get bad they wont make a good connection and things will start to heat up....then start arcing. If you can take the F/R switch apart you can file or sand the contacts flat (if they aren't to wore out) and get some more life out of them....or just replace the whole assembly. You can pull the (what I call a puck) off with one nut on the back of switch...and then you can see the contacts.
roady89 is offline   Reply With Quote
Unread 05-13-2008, 11:25 AM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Apr 2008
Location: Baton Rouge, La.
Posts: 4
Smile Re: First time cart owner and after 2 months, it stopped working!

Thanks guys for all your info. Where is a good and affordable place to get parts for an EZ?
notredave is offline   Reply With Quote
Unread 05-13-2008, 01:33 PM   #6
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: First time cart owner and after 2 months, it stopped working!

Give cartszone a call...they have lots of electric stuff. Any one of the vendors should have the switch or contacts.
roady89 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
engine tring to run after cart is stopped Gas Club Car
Brand Noob Cart Owner w/Questions Electric EZGO


All times are GMT -5. The time now is 10:18 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.