lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-01-2008, 09:54 PM   #11
Not Yet Wild
 
1986g3a's Avatar
Yamaha
 
Join Date: Jun 2008
Location: ca
Posts: 65
Default Re: EZGO 2003 PDS SPeed CHip Placement

It is the same as checking the diagnostic code. The code that is Given will tell you that you have properly installed the chip. 4 beeps for the Red Freedom chip, 2 for the Blue Steep Hill chip, 3 for the Yellow Mild Hill chip. 1 beep means you have no chip programmed. Once you hear the beeps confirming you have installed the chip then you can take it out and still get the performance of the chip. If you purchase you cart from a dealer most of them will ask you if you want the upgrade and charge you for the chip. What they really do is reprogram the controller and keep the chip.
1986g3a is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-03-2008, 01:01 PM   #12
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 25,356
Default Re: EZGO 2003 PDS SPeed CHip Placement

I just checked this info with an E-Z-Go tech, and he says you're right AND wrong.

It will work as you described UNTIL the switch is moved to the TOW position. Then when moved back to RUN the controller will default to the ALL TERRAIN setting.

This would surely upset the customer!
gornoman is offline   Reply With Quote
Unread 06-03-2008, 09:28 PM   #13
Not Yet Wild
 
1986g3a's Avatar
Yamaha
 
Join Date: Jun 2008
Location: ca
Posts: 65
Default Re: EZGO 2003 PDS SPeed CHip Placement

At the shop/dealership I work for we were told by the EZGO rep that the controller would not reset unless you lost your voltage coming from the batteries. But everytime I have installed one I alwlays leave it in. The customer paid for it.
1986g3a is offline   Reply With Quote
Unread 06-03-2008, 09:36 PM   #14
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,923
Default Re: EZGO 2003 PDS SPeed CHip Placement

You are in not reprogramming the controller. You also have to leave the plug in. I am with gorno...never heard of it done like that. Tow mode....unplug plastic plug with wires....plug in new plastic plug with wires.....put in run mode and your set. I don't know why they call it a "chip" when its a **** $1 plastic plug with some wires in it. What I really hate is these shady dealers and theiving guys on ebay who want to charge $50 for a part that cost $1 (or less) at any decent electronics dealer.
roady89 is offline   Reply With Quote
Unread 06-03-2008, 09:47 PM   #15
Not Yet Wild
 
1986g3a's Avatar
Yamaha
 
Join Date: Jun 2008
Location: ca
Posts: 65
Default Re: EZGO 2003 PDS SPeed CHip Placement

I have often thought of mass producing theese things and selling them for $10. You could make a killing. The only thing is, I wonder if there is a patent for it, I think thats how you spell it.
1986g3a is offline   Reply With Quote
Unread 06-04-2008, 07:25 AM   #16
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 25,356
Default Re: EZGO 2003 PDS SPeed CHip Placement

They are $4 on ebay. (+ $5 S&H!)
gornoman is offline   Reply With Quote
Unread 07-03-2008, 11:08 PM   #17
Not Yet Wild
E-Z-GO
 
Join Date: May 2008
Location: North Carolina
Posts: 33
Default Re: EZGO 2003 PDS SPeed CHip Placement

Best I can tell, the chip has to stay in. Toggling the F/R switch to Reverse 5 times puts the controller in diagnostic mode and the first beeps tell you what chip is in the speed control slot, according to the service manual. Have never heard the chip doesns't have to stay in, as all but the "all terrain" chip have wires. However, the all terrain is just an open plug, so it might be that the controller is programable, but it is an E-Z-GO secret, as it is not addressed in the Service Manual.

I would like to confirm this, as well. Not disputing it is programmable, but just never heard that. Always see the chip in the slot. You can take an all terrain chip and make your on using 16 AWG wire using the manul on this site's home page.

Last edited by captkirknc; 07-03-2008 at 11:11 PM.. Reason: Left ut a key word...need to preview better....lol
captkirknc is offline   Reply With Quote
Unread 07-15-2009, 03:34 PM   #18
Not Yet Wild
 
Join Date: Jul 2009
Posts: 6
Default Re: EZGO 2003 PDS SPeed CHip Placement

just got through doing my 2004 txt pds e-z go.
downloaded the manual and followed the procedure.
1 turn the "run - tow" switch to tow.
2 remove the cover (controller enviromental cover).
3 plug in the jumper (chip).
4 replace the cover.
5 turn the "run - tow" switch back to run.
to find out what mode it changed to
toggle the forward/reverse switch from NEUTRAL TO REVERSE 5 times
a few seconds after the 5th toggle (beep) you will hear one of the following.
1 beep for all-terrain 13.5 mph
2 beeps for steep hill 13.5 mph
3 beeps for mild hill 14.5 mph
4 beeps for freedom 19 mph
after all this turn the "run - tow" switch back to tow then to run to escape the diagnostic mode ...then go drive and hang on.

It works great. With the "freedom" mode you loose some low end torque and gain the top end speed. The jumper I got had red wires (if that makes a difference)
captgrey is offline   Reply With Quote
Unread 07-15-2009, 10:14 PM   #19
72 volts!
 
Andy4639's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Liberty SC, Garden City SC
Posts: 5,412
Default Re: EZGO 2003 PDS SPeed CHip Placement

How can it stay in the mode if there is nothing plug into it. The All Terrain plug is nothing but a plug with no wires. So if you don't have a chip plug in the controller it's in All Terrain mode.
Andy4639 is offline   Reply With Quote
Unread 07-15-2009, 10:47 PM   #20
Not Yet Wild
 
Join Date: Jul 2009
Posts: 6
Default Re: EZGO 2003 PDS SPeed CHip Placement

I'm not sure if this reply is directed at my post, however if so I don't understand!
Obviously there is a default mode if there is no jumper present.
The diagnostic will still indicate the mode/ status "performance option" whatever you want co call it reguardsess ????
Are we just splitting hairs or symantics?
This procedure I posted was intended to share what I learned from the service manual.
Was there something I left out? Or didn't make clear?
captgrey is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
2003 club car IQ DS speed setting Electric Club Car
2003 ezgo just slows down Electric EZGO
Surging speed and RPMs on my 2003 CC Electric Club Car
Finding speed chip? Electric EZGO
problems with 2003 ezgo Electric EZGO


All times are GMT -5. The time now is 03:35 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.