lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-26-2011, 07:02 PM   #1
Not Yet Wild
 
Join Date: Oct 2010
Posts: 31
Default Charging Issue/ Battery Issue?

I have a 95 ezgo electric with trojan batteries. When I go to charge it, it starts with the normal charge cycle but says they are 80% charged after about 10 minutes. The cart will not run long after that but all batteries read 6.3 when charged. I tried to test them with the tube tester thing but am really not sure on how to read it. Any ideas?
rstov is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-26-2011, 07:12 PM   #2
go to cartsunlimited.net
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 68,533
Default Re: Charging Issue/ Battery Issue?

My guess is a bad charger circuit board.

Can you find another charger to try on your cart or another cart to try your charger on?
scottyb is offline   Reply With Quote
Unread 06-26-2011, 09:53 PM   #3
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Charging Issue/ Battery Issue?

you really need to have them load tested, they could be holding voltage fine but there could be an issue with a load on.......................
shadowman is offline   Reply With Quote
Unread 06-29-2011, 10:46 AM   #4
Not Yet Wild
 
Join Date: Oct 2010
Posts: 31
Default Re: Charging Issue/ Battery Issue?

I did try another charger that I know worked and it charged quickly as well but batteries did not hold a charge long. Do I have to take them somewhere to be load tested?
rstov is offline   Reply With Quote
Unread 06-29-2011, 12:53 PM   #5
Getting Wild
 
OlManRivah's Avatar
E-Z-GO
 
Join Date: Apr 2010
Location: Virginia
Posts: 94
Default Re: Charging Issue/ Battery Issue?

Quote:
Originally Posted by rstov View Post
I tried to test them with the tube tester thing but am really not sure on how to read it.
Stick it in a battery water hole and draw enough water into the tube to float the thingy inside. The specific gravity will be read looking at the tester with the thingy floating. Write down each value of each battery and post on the forum.

Do this on a full charge ( or best your charger will do). Also voltages of each battery would be nice. May have one real bad battery. I suspect all have seen their best days.
OlManRivah is offline   Reply With Quote
Unread 06-29-2011, 03:03 PM   #6
The Last Moja Morani
 
shadowman's Avatar
Club Car
 
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: Charging Issue/ Battery Issue?

you can load test them yourself with a voltage meter......can you use one?......................
shadowman is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Charging issue Electric Club Car
Charging issue... Electric EZGO
Charging issue Columbia ParCar
Par car charging issue. Gas Columbia ParCar
Another battery charging issue Electric Club Car


All times are GMT -5. The time now is 07:09 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2019, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.