lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 05-26-2008, 04:10 PM   #1
Not Yet Wild
 
Join Date: May 2008
Posts: 2
Default Battery Cable To Motor

rECENTLY WHILE DRIVING MY EZG AROUND THE NEIGHBORHOOD WE NOTICED AN ODOR SMELLED LIKE HOT OR OVER HEATED WIRE. AFTER EXAMING THE WIREING I DISCOVERED THAT THE SINGLE WIRE THAT GOES FROM THE WIREING JUNCTION TO THE MOTOR WAS VERY HOT. cOULD THIS BE DUE TO POOR CONNECTION BETWEEN THE JUNCTION BOX AND THE MOTOR, WATER LEVELS ARE ALL OK. DURING THE TIME WE SMELLED THIS ODOR THE MOTOR DID NOT FALTER AND SLOW DOWN. tHANKS FOR YOUR TIME. PAUL
Paul P. is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 05-26-2008, 04:34 PM   #2
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: Battery Cable To Motor

Welcome Paul P...................

Sure sounds like a loose connection.................

Lets get some input from others.................
rusty is offline   Reply With Quote
Unread 05-26-2008, 06:55 PM   #3
Gone Wild
 
sundownshifter's Avatar
Club Car
 
Join Date: Feb 2007
Location: INDIANA
Posts: 2,096
Default Re: Battery Cable To Motor

WELCOME!!
sundownshifter is offline   Reply With Quote
Unread 05-28-2008, 05:09 PM   #4
Not Yet Wild
 
Join Date: May 2008
Posts: 7
Default Re: Battery Cable To Motor

Welcome,I had the same problem with smelling wires.I just changed everything to 4 gauge wire,and when I pulled one of the wires going to the motor it had a bare place on it and it had corrosion built up on it.It had been rubbing on the loop that holds the wires in place.I never would have found it if I hadn't pulled it completely out.I don't know if that was my problem,but I know it couldn't help things.
I've got a 95 EZGO medalist, and I took the right back tire off,and that loop is right there.Maybe this will help you.
nothinbutalittle is offline   Reply With Quote
Unread 05-28-2008, 06:00 PM   #5
Not Yet Wild
 
Join Date: May 2008
Posts: 2
Default Re: Battery Cable To Motor

Thank you I really appreciate the answer and I will try it immediately.
Paul
Paul P. is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
06 Precedent Battery cable spark. Electric Club Car
Club Car Battery Cable - Pictures Gas Club Car
Roady89's Battery Cable Review Garage and Workshop
choke cable Gas Yamaha


All times are GMT -5. The time now is 02:41 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.