lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-03-2011, 06:54 PM   #1
Gone Wild
 
as350pilot's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: Florida
Posts: 516
Default Need help getting '97 TXT to run...

I am in need of assistance... I have a '97 Ezgo TXT DCS that is stock except for a PQ Bandit upgraded motor. My cart just stopped working. I reviewed the DCS troubleshooting guide, and I narrowed it down to the solenoid not working. It did not click or make any noise. I received a new 36v solenoid today and installed it, and everything is still the same... No noise, no nothing.

I followed the DCS (DCS Troubleshooting) troubleshooting guide to the T. I tested the 10 pin connector with my VOM and everything was correct per the document. My battery pack show 37.12 volts. When I put the VOM on the battery side of the solenoid I get 37.12 volts. When I put the VOM on the controller side of the solenoid I get 37.12 volts, which according to the guide is an indication of the solenoid being bad. Is it really possible to have bad solenoids like that or is there something else going on?

The first picture below is my original wiring for the solenoid. The second is the new one.


as350pilot is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-03-2011, 06:57 PM   #2
Gone Wild
 
Spawn's Avatar
E-Z-GO
 
Join Date: Dec 2010
Location: Jax FL
Posts: 596
Default Re: Need help getting '97 TXT to run...

Do you have a diode and resistor installed?
Spawn is offline   Reply With Quote
Unread 08-03-2011, 07:04 PM   #3
Gone Wild
 
as350pilot's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: Florida
Posts: 516
Default Re: Need help getting '97 TXT to run...

Quote:
Originally Posted by Spawn View Post
Do you have a diode and resistor installed?
Nope, the original didn't have either.
as350pilot is offline   Reply With Quote
Unread 08-03-2011, 07:20 PM   #4
BGW Sponsor
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 67,063
Default Re: Need help getting '97 TXT to run...

The originally a resistor board with diodes in stalled on the solenoid.
scottyb is offline   Reply With Quote
Unread 08-03-2011, 07:57 PM   #5
Gone Wild
 
as350pilot's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: Florida
Posts: 516
Default Re: Need help getting '97 TXT to run...

Quote:
Originally Posted by scottyb View Post
The originally a resistor board with diodes in stalled on the solenoid.
Is that something I can make up? If so where could I find how? I am very good with soldering, and electronics, I would just need to know some details..
as350pilot is offline   Reply With Quote
Unread 08-03-2011, 08:54 PM   #6
BGW Sponsor
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 67,063
Default Re: Need help getting '97 TXT to run...

Contact members Gamin, forbruce, and sonic I'm sure they will be happy to help you make your own DCS resistor board
scottyb is offline   Reply With Quote
Unread 08-03-2011, 10:05 PM   #7
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 25,367
Default Re: Need help getting '97 TXT to run...

Quote:
Originally Posted by scottyb View Post
Contact members Gamin, forbruce, and sonic I'm sure they will be happy to help you make your own DCS resistor board
Zing!

But seriously, does the reverse alarm still sound when you select reverse?
gornoman is offline   Reply With Quote
Unread 08-04-2011, 06:55 AM   #8
Gone Wild
 
as350pilot's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: Florida
Posts: 516
Default Re: Need help getting '97 TXT to run...

Quote:
Originally Posted by gornoman View Post
Zing!

But seriously, does the reverse alarm still sound when you select reverse?
Yes it does. I don't understand why the cart worked fine with no resistor board; stopped working with all indications that it was the solenoid, then with a replacement solenoid it still doesn't work. How could it possibly just suddenly need the resistor board. I am not doubting anyone that has given advise, I am just trying to understand...
as350pilot is offline   Reply With Quote
Unread 08-04-2011, 07:25 AM   #9
BGW Sponsor
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: Southern California
Posts: 67,063
Default Re: Need help getting '97 TXT to run...

The resistor and diode are part of the system, their function is to pre-charge the controller and dissipate fly back voltage at the solenoid. They protect both the solenoid and the controller.

I wouldn't recommend an aftermarket motor on a stock DCS controller. The stock DCS control is the weak point of that drive system.
scottyb is offline   Reply With Quote
Unread 08-04-2011, 09:11 AM   #10
Gone Wild
 
rabbitreborn's Avatar
E-Z-GO
 
Join Date: Jun 2010
Location: Central Florida
Posts: 2,704
Default Re: Need help getting '97 TXT to run...

Quote:
Originally Posted by scottyb View Post
I wouldn't recommend an aftermarket motor on a stock DCS controller. The stock DCS control is the weak point of that drive system.
Now there is an understatement.........
rabbitreborn is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 09:12 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.