lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-02-2008, 11:59 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2008
Location: Rockwall, TX
Posts: 6
Unhappy 98 TXT Dead

The cart is a 1998 36v Non DCS/PDS cart
Here is the deal. I have messed something up doing the simplest of tasks. I was trying to hook up an analog state of charge meter. I wanted to hook it up via the key switch, and I think this is where my issues arose. I connected the negative side of the gauge to the neg post of the 6th battery. I used a small wire to test the key switch for positive. I tried it with the key off then with the key on. I never had any sparks, burning smell or anything. Since I didn't get any response on the meter I decided for the sake of time to just wire directly to the poss of battery 1 and the meter worked as expected. I get it all wired and attempt to back the cart out of the garage, and NOTHING. There is not buzzer sound when in reverse, and no clicking in the solenoid. Can someone tell me where to begin to look for my issue?
Thanks
txbug is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-02-2008, 12:01 PM   #2
Gone Wild
E-Z-GO
 
Join Date: Apr 2008
Location: Wichita, KS
Posts: 1,519
Cool Re: 98 TXT Dead

Welcome txbug! Help is on the way!
EZ-GOnewild is offline   Reply With Quote
Unread 06-02-2008, 12:08 PM   #3
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: 98 TXT Dead

Welcome to BGW txbug.....................

Go back over the connections you worked with.............. the big cables have got to be tight. If they will move by tugging on them, tighten them.
rusty is offline   Reply With Quote
Unread 06-02-2008, 01:19 PM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2008
Location: Rockwall, TX
Posts: 6
Default Re: 98 TXT Dead

Thanks for the welcome and the advice guys. I'm sure the connections are tight. I have read many posts before and that is usually the first thing everyone says to check is the cable connections. My batteries are only a year old, and when I replaced the batteries I replaced the cables as well. I am, though, concerned that the terminal corrosion prevention spray may have gotten on the cable connectors. I wouldn't think that would stop conductivity, but you never know. When I get home I am going to clean the wire connections, terminals, slightly sand and reconnect. If the connection isn't the issue what should be my next step?
txbug is offline   Reply With Quote
Unread 06-02-2008, 02:14 PM   #5
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: 98 TXT Dead

You could have blown your reed switch.

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 06-02-2008, 02:58 PM   #6
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2008
Location: Rockwall, TX
Posts: 6
Default Re: 98 TXT Dead

Thanks Mike. I am going to do some diagnosis tonight. If I do find that it is the reed switch, do you have them in stock? If I can't diagnose the problem myself I will be seeing you.
txbug is offline   Reply With Quote
Unread 06-02-2008, 11:23 PM   #7
Gone Wild
 
mikesmotortoys's Avatar
E-Z-GO
 
Join Date: Mar 2008
Location: Rockwall, Texas (Dallas / Ft. Worth)
Posts: 7,077
Default Re: 98 TXT Dead

Funny, didn't see that you were my homeboy in Rockwall! Yes - we have them...

Have I seen this cart before?

Factory EZGO - Bad Boy Buggy - Dixie Chopper Mowers
mikesmotortoys is offline   Reply With Quote
Unread 06-03-2008, 07:43 AM   #8
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2008
Location: Rockwall, TX
Posts: 6
Default Re: 98 TXT Dead

No you have not seen the cart. I did purchase the state of charge meter from you, and I came in the other day to get the rivets. I will see you Saturday to get the reed switch. That was the issue. Thanks again for your help.
Ken
txbug is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
dead ez-go Electric EZGO
Inherited Dead Club Car Electric Club Car
dead or alive????? Lifted Golf Carts
Dead 2005 EZ-go Electric EZGO


All times are GMT -5. The time now is 10:24 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.