lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 06-05-2008, 10:09 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2008
Posts: 2
Smile 94 ezgo speed problem

hello, new to forum but like everyone i have and issue i just cant put my finger on what exactly is the problem....when u first turn on cart, engage f/r switch cart it will jump like it is going to take off and than it will barely move either way but if u keep moving cart back n forth it will finally kick in and act normal. u can climb hills or drive for several miles without a hitch..If u stop u might have to go thru same process again to get it to go normal again. i have tested everything i can find spec's on and still cant narrow down. battery votage is 37.4 each has been load tested and hydro'd and results overall are slightly "weak". solenoid B+ gets 37.4 and same at controler side after pedal engage. curtis 1204 controler seems to be working according to curtis spec's the only thing that may be out of spec is my throttle "POT" the ohms test went from 20ohm (no pedal) to 6500 (full pedal) book said 5500 should be max and i couldnt really find what input voltage should be to controler connect #2 and #3 for this for throttle control..as u can see i really dont want to spend 2-400.00 to replace controller if i dont need to any other thing that might cause and how to test it
EASTSIDEPOWER@CHARTER.NET is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 06-05-2008, 02:35 PM   #2
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: 94 ezgo speed problem

Welcome EASTSIDEPOWER@CHARTER.NET..................

What year is your E-Z-GO?

Could be brushes in the motor..............
rusty is offline   Reply With Quote
Unread 06-05-2008, 03:43 PM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2008
Posts: 2
Default Re: 94 ezgo speed problem

it is a 94 model standard system with a curtis 1204 contoller.....i would think that brushes would give me trouble all the time but once it gets going it will work until u cut it off
EASTSIDEPOWER@CHARTER.NET is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
EZGO 2003 PDS SPeed CHip Placement Electric EZGO
2002 EZGO PDS speed problem Electric EZGO
speed problem Electric EZGO
Speed Upgrades for a TXT EZGO Electric EZGO
Ezgo speed cart for sale Golf Carts and Parts


All times are GMT -5. The time now is 06:31 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.