lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 06-20-2008, 02:14 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2008
Location: South Carolina
Posts: 7
Default 1994 EZGO Problem "Slipping"

I just purchased a 1994 cart and charged it up. When I depress the pedal it starts to move then just stops and starts to vibrate like something is slipping. It sounds like the motor is running but not turning the drive?
Tigerragg is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 06-20-2008, 02:21 PM   #2
Administrator
Club Car
 
Join Date: Jun 2007
Posts: 12,550
Default Re: 1994 EZGO Problem "Slipping"

Could be a few different things.

1. Axle hubs are stripped. Common on ezgo's
2. Splined coupling on motor is stripped.
3. Differential is broken.

I would check to see if the axle nut is spinning when it does what you describe. If its not the axle nut then you will have to pull the motor and check the motor coupling.

Golf Carts | Lifted Golf Carts | Electric Golf Carts

Club Car Golf Cart | E-Z-GO Golf Cart | Yamaha lift kits | Harley Davidson Golf Cart | Cushman Golf Cart | Pargo Golf Cart | Columbia Golf Cart | Taylor Dunn Golf Cart

Quote:
Originally Posted by azboo
Roady, your brand of evil should be bottled and sold......for bunches of money.
roady89 is offline   Reply With Quote
Old 06-20-2008, 11:04 PM   #3
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,240
Default Re: 1994 EZGO Problem "Slipping"

Welcome to the forum Tigerragg.....................
rusty is offline   Reply With Quote
Old 06-21-2008, 09:53 AM   #4
Just me. .
 
phasetim's Avatar
Club Car
 
Join Date: Sep 2007
Location: Pensacola, FL
Posts: 1,092
Default Re: 1994 EZGO Problem "Slipping"

Could also be failing batteries..
phasetim is offline   Reply With Quote
Old 06-21-2008, 10:11 AM   #5
Stay thirsty my friends!
 
gornoman's Avatar
Mixed Breed
 
Join Date: Jan 2007
Location: Suburban Chicago
Posts: 22,893
Default Re: 1994 EZGO Problem "Slipping"

Quote:
Originally Posted by phasetim View Post
Could also be failing batteries..
Absolutely, and the #1 problem for the symptoms he described. Get a multimeter on those batts and see whats going on.
gornoman is offline   Reply With Quote
Old 06-23-2008, 06:20 AM   #6
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2008
Location: South Carolina
Posts: 7
Default Re: 1994 EZGO Problem "Slipping"

Thanks for the advise. I will start with the batteries and work from there.
Tigerragg is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
"slow" Precedent "need Speed" Gas Club Car
Wheels and Tires in So Cal 22" paddles on Douglas, 25" Dunlop on ITP, 27" ITP's Golf Carts and Parts
MuayThai41's TXT bodied 95 EZGO "El Gato" On Road Golf Carts!


All times are GMT -5. The time now is 01:16 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.