lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 12-21-2011, 10:48 AM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2011
Location: Michigan
Posts: 11
Default Lift kit problem please help!

I ordered a lift kit for my '95 ezgo medalist from Ebay. It came with new bigger tires and wheels. The lift kit replaced the existing from assembly completely. The model ezgo that I have has a tie rod that goes from the steering assembly to the right tire and then a long tie rod goes from the right assembly to the left tire assembly. The problem I am having is the existing long link that goes from right to left is not long enough. Its about 5" short. What they sent in the kit was two short(12") extensions but no matter what I do I can't seem to make anything work. Besides going to a fab shop somewhere local, does anyone have any suggestions? Any help would be wonderful.
rohnsherd is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 12-21-2011, 11:52 AM   #2
REAL MEN GET EM DIRTY
 
blake80's Avatar
E-Z-GO
 
Join Date: Jun 2009
Location: rincon , ga.
Posts: 3,646
Default Re: Lift kit problem please help!

which lift kit did you get?
post a pic of your steering if you can.
blake80 is offline   Reply With Quote
Unread 12-21-2011, 12:25 PM   #3
Gone Mad
E-Z-GO
 
Join Date: Oct 2009
Location: Buford, GA
Posts: 7,120
Default Re: Lift kit problem please help!

Quote:
Originally Posted by rohnsherd View Post
I ordered a lift kit for my '95 ezgo medalist from Ebay. It came with new bigger tires and wheels. The lift kit replaced the existing from assembly completely. The model ezgo that I have has a tie rod that goes from the steering assembly to the right tire and then a long tie rod goes from the right assembly to the left tire assembly. The problem I am having is the existing long link that goes from right to left is not long enough. Its about 5" short. What they sent in the kit was two short(12") extensions but no matter what I do I can't seem to make anything work. Besides going to a fab shop somewhere local, does anyone have any suggestions? Any help would be wonderful.
Could you use threaded rod and a rod coupler to lengthen it? I'm not sure whether it's RH or LH threaded, and it would be much flimsier than stock.
yurtle is offline   Reply With Quote
Unread 12-24-2011, 09:20 AM   #4
Not Yet Wild
E-Z-GO
 
Join Date: Dec 2011
Location: Michigan
Posts: 11
Default Re: Lift kit problem please help!

So I tried the threaded rod route but found that even using that, I ended up with both ends being rh thread and the ball joints are threaded opposite each other for adjustment. I found a solution. I took the original steering linkeage to a fabricator and I am having them cut and weld in a 4" piece to lengthen it. I believe this will be the solution. Thanks for the help everyone.
rohnsherd is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
G14 7" allsport lift problem Lifted Golf Carts
Allsports a-arm lift problem Gas Club Car
lift problem Gas EZGO
lift problem? Lifted Golf Carts
camber problem with lift Lifted Golf Carts


All times are GMT -5. The time now is 06:25 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.