lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 01-28-2012, 02:29 PM   #1
Not Yet Wild
 
Join Date: Jan 2012
Posts: 2
Default Turn Signal Help

I have a 99 EZGO electric (36v). The cart was given to me a few years ago and I have been slowly fixing it up. The turn signals have never worked. The headlights, markers, and brake lights all work fine. I am using the wiring diagram below (my cart's electrical system is exactly like the diagram). My meter measures 12v going into the flasher (X on flasher), and I get 12v on the yellow wire that goes from the flasher (L on flasher)to the turn signal switch (it is a VSM 900). When I flip the turn signal switch (left/right turn), the flasher's L prong goes to zero volts. I'm not sure what to test next, or if I need to replace the flasher? Any help will be appreciated. Thanks!
Attached Images
File Type: jpg GCWiring2.jpg (43.7 KB, 11 views)
File Type: jpg IMG_1789.jpg (69.1 KB, 11 views)
File Type: jpg IMG_1787.jpg (48.9 KB, 5 views)
UliKunkel is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 01-28-2012, 04:08 PM   #2
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 14,385
Default Re: Turn Signal Help

Welcome to BGW

Unless the brake light switch is closed, what you should see at on the yellow wire from flasher to turnsignal box is steady 12V with no turn selected and intermittent 12V if L or R turn is selected.

I'd replace the flasher before dig into the turnsignal box any further.
JohnnieB is offline   Reply With Quote
Unread 01-31-2012, 10:24 AM   #3
Not Yet Wild
 
Join Date: Jan 2012
Posts: 2
Default Re: Turn Signal Help

That was it, I got a new flasher and the signals work now. My problem was, I got a new flasher a few weeks ago and the turn signals still did not work. I just figured out a few days ago, that I got the wrong flasher. I got the correct flasher yesterday and it works great now. Sorry for taking your time to solve this easy problem! Thanks for the help!
UliKunkel is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
No turn signal Electric EZGO
Turn signal help Lifted Golf Carts
turn signal help Electric EZGO
Turn signal Electric EZGO
turn signal Test Post


All times are GMT -5. The time now is 03:15 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.