lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 05-25-2012, 12:40 AM   #1
Not Yet Wild
 
Join Date: Feb 2012
Posts: 8
Smile 2007 pds runs for a while then stop

Hi all,
my buddy has a 07 pds cart. it runs a mile or two then barely makes it home. voltage across pack is 38.1. Charger will never shut off on his or my charger. The meter stays around 10 on both of our chargers but will charge forever if left plugged in. solenoid? all battery voltage good, cables good. all thoughts appreciated, thanks.
patpaget is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 05-25-2012, 06:26 AM   #2
Getting Wild
 
FF Titus's Avatar
 
Join Date: Jul 2011
Location: Rhode Island
Posts: 144
Default Re: 2007 pds runs for a while then stop

If you've load tested the cars batteries and they test fine and cables being good, then that rules that out.

Since it's a PDS, flip the switch from run to tow back to run. Key switch off, and put it in reverse 5 times, then wait for the beeps. Report back what it says.
FF Titus is offline   Reply With Quote
Old 05-25-2012, 06:56 AM   #3
LET IT RUN
E-Z-GO
 
Join Date: Apr 2009
Location: FT Lauderdale FL.
Posts: 10,709
Default Re: 2007 pds runs for a while then stop

Welcome to BGW

did you get that 38.1 reading while the batteries were on the charger??, if the charger is not shutting off by it's self, you have some bad batteries, the charger need to see 44 to 46 volts before the charger will turn off
rib33024 is offline   Reply With Quote
Old 05-25-2012, 06:59 AM   #4
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 8,059
Default Re: 2007 pds runs for a while then stop

Welcome to BGW!

If the two chargers turn off normally on your cart, but neither will turn off on your buddy's cart, something is wrong with your buddy's cart.
The battery pack is the most likely suspect since only running a couple miles also points to battery issues.
(Short run time can be caused by a mechanical drag, a defective motor and some other things, but two symptoms are pointing at batteries.)

What are the individual battery on-charge voltages after they have been on the charger for 6-8 hours?
Automatic 36V chargers don't turn off automatically until pack voltage is in the 44-46 Volt range, or about 7.3-7.6 Volts per battery.

When did you get the 38.1V measurement?
Shortly after the batteries came off the charger, or 12 hours later, or after the cart crawled home?

What are the individual battery voltages 12 hours after the come off charge?
What are the individual battery voltages immediately after cart crawls home?

Put cart in diagnostic mode. Are any error codes heard while crawling home?
If so, which one or ones?

Also, while they probably are not causing the reported symptoms, all 10 stock high current cable need to be replaced. Mine looked good, but I picked up some torque when I replaced them. Didn't change top speed because PDS controller limits motor RPM, but gets to that limit quicker.
JohnnieB is online now   Reply With Quote
Old 05-25-2012, 08:51 AM   #5
Not Yet Wild
 
Join Date: Feb 2012
Posts: 8
Default Re: 2007 pds runs for a while then stop

38.1 volt reading was after Cart had charger (never shut off) and
Driven around the block. Ill test again, but all batteries
Were 6.1 -6.3 volts. Should batteries voltage be higher ?
Thanks all. I'll do the diagnostic code thing soon
patpaget is offline   Reply With Quote
Old 05-25-2012, 09:38 AM   #6
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 8,059
Default Re: 2007 pds runs for a while then stop

Quote:
Originally Posted by patpaget View Post
1. 38.1 volt reading was after Cart had charger (never shut off) and
Driven around the block.
2. Ill test again, but all batteries
Were 6.1 -6.3 volts.
3. Should batteries voltage be higher ?
4. Thanks all. I'll do the diagnostic code thing soon
1. Driving around block ought to have depleted surface charge pretty well, so 38.1V is a reasonable voltage, but the battery voltage not getting high enough to turn off charger(s) is an issue.

2. The Min/Max voltage spread is a little high, but doesn't wave a red flag.

3. Yes. 6.1V is only a 55% charge and 6.3V is only a 90% charge.
Attached is a State of Charge chart. Note the voltage readings are after the batteries have rested for 12 hours (Or driven around block - about a mile?)

The real question is, what are the voltages when cart will hardly run?
If there is a bad battery or batteries, it/they will have much lower voltage than the others.

4. Here's a picture of the PDS label. It's easier to read on the screen than standing on your head under the cart seat.
Attached Images
File Type: jpg StateofChargeChart.jpg (53.8 KB, 0 views)
File Type: jpg PDS Label on Controller Cover.JPG (142.9 KB, 0 views)
JohnnieB is online now   Reply With Quote
Old 05-29-2012, 08:41 AM   #7
Not Yet Wild
 
Join Date: Feb 2012
Posts: 8
Default Re: 2007 pds runs for a while then stop

After charge. 37.3 across pack. All batteries 6.2 or 6.3.
Tried the diagnostic test - just got one long beep like reverse buzzer am I doing it wrong ? Battles have water cable all good.
Thanks all help appreciated.
patpaget is offline   Reply With Quote
Old 05-29-2012, 10:23 AM   #8
Carts Unlimited
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: So Cal
Posts: 50,839
Default Re: 2007 pds runs for a while then stop

Sounds like bad battery (batteries) to me. Do this:
Connect the meter to the pack and drive.

What is the voltage before you start.

And what is the voltage when you press the peddle all the way down?

And lastly what is the voltage when the cart is in "barely makes it home" mode?
scottyb is offline   Reply With Quote
Old 05-29-2012, 10:57 AM   #9
Not Yet Wild
 
Join Date: Feb 2012
Posts: 8
Default Re: 2007 pds runs for a while then stop

Scotty,

Voltage when starting out..37.2 after a charge drove across the street.

First pressed on pedal, voltage 28.5 area

got home barely voltage was about 27.1 stopped cart voltage 33.6.

Cart very sluggish, felt like a car out of gas...voltage ranged down to 26.9 up

to 33.4 while driving...seems like batteries to me but what do i know???
patpaget is offline   Reply With Quote
Old 05-29-2012, 12:06 PM   #10
Not Yet Wild
 
Join Date: Feb 2012
Posts: 8
Default Re: 2007 pds runs for a while then stop

btw, 4 beeps
patpaget is offline   Reply With Quote
Reply

Tags
ezgo, pds
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Runs 10 minutes then shuts off, wait 5 then runs again... Electric EZGO
runs good cold runs bad hot? Gas EZGO
Reverse...runs awesome Forward..runs bad Gas EZGO
Cart runs fine, stop, won't start back Gas Club Car
After recharging, cart only briefly runs, then slows to stop Electric EZGO


All times are GMT -5. The time now is 12:55 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.