lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-16-2008, 07:12 PM   #1
Not Yet Wild
 
Join Date: Jul 2008
Posts: 2
Default cart just died.

Hi guyz I am a new member to this forum and also new to golf carts in general. I own a 93 ezgo textron. Here is what i have done so far. I was given this cart because previous owner said it was unrepairable. After looking into the problem the axle bearing came apart and slid out of the diff causing it to not move.So after repairing the bearing I replaced the bearings that the motor drives off of and the same time I replaced the motor with a newer motor off a newer ezgo. Now today I rode it for the first time and it ran great then just cut out all at once. It only clicks when I hit the pedal in forward and reverse. The battery is fully charged. What should be my next step to figuring this out. Thanks for the help guyz.
k_dencuz is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-16-2008, 08:52 PM   #2
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: cart just died.

Welcome to the forum k_dencuz...........................
rusty is offline   Reply With Quote
Unread 07-16-2008, 11:04 PM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Jun 2008
Location: louisiana
Posts: 35
Default Re: cart just died.

theres a forum on here that shows how to test the motor!dont remember where i'll look and send it to u!
eznogo is offline   Reply With Quote
Unread 07-17-2008, 01:24 PM   #4
Not Yet Wild
 
Join Date: Jul 2008
Posts: 2
Default Re: cart just died.

ok so I searched the forum and somewhere said to jump the b- and m- terminal and that made the cart move. Now what would cause this problem? I checked resistance on the 2 wires going to the controller from the throttle and resistance was .6 ohm throttle closed and 5.8 ohm WOT.help please.
k_dencuz is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Cart Died after going down bumpy road Gas EZGO
Electric Club Car Died - HELP Electric Club Car
1992 EZ Go Freedom died help Electric EZGO
82 ezgo that died Electric EZGO
Golf cart died!!!! Electric EZGO


All times are GMT -5. The time now is 10:05 AM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.