lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 07-29-2008, 12:26 PM   #1
Not Yet Wild
 
Join Date: Jul 2008
Posts: 2
Default 98 EZ GO won't go

We've got a 1998 EZGO we use in our business. It quit a few days ago. We have checked the batteries (getting a full 36 volts), replaced solenoid, replaced controller (with rebuilt), replaced microswitch & accelerator shaft housing. Key switch is ok & we have power showing up at all required locations. Yet, when we switch to forward or reverse, nothing happens. Any suggestions before we take to repair shop? also checked all cables. Thanks
trguy4820 is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 07-29-2008, 01:53 PM   #2
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: 98 EZ GO won't go

Welcome to the forum trguy4820...................

Most of the time, the problem is loose or dirty cable connections. Did you remove and clean each cable with a wire brush? (This is a fix 98% of the time)

The reed switch in the "body side" of the charger recepticle will also cause these conditions.

Do you not hear the reverse buzzer when in reverse?

Do you not hear the relay click when you press the accelerator pedal?

If you don't hear the reverse buzzer, it's usually bad cable connections.
rusty is offline   Reply With Quote
Unread 07-29-2008, 06:07 PM   #3
Not Yet Wild
 
Join Date: Jul 2008
Posts: 2
Default Re: 98 EZ GO won't go

Thanks Rusty,

We have done all you suggested except actually clean the cable ends. I'll tell the guys in the morning to actually clean cables and see if it helps. The reverse buzzer does ring.

Again, thanks
trguy4820
trguy4820 is offline   Reply With Quote
Unread 07-31-2008, 02:04 AM   #4
72 volts!
 
Andy4639's Avatar
E-Z-GO
 
Join Date: Jan 2007
Location: Liberty SC, Garden City SC
Posts: 5,412
Default Re: 98 EZ GO won't go

1998 model DCS try playing with the little micro switches attached to the Forward/ Reverse cam under the seat.
If that doesn't help take the floor mat up take the 4 screws out of metal cover and see if the micro switch is broke.
This is what you are looking for.




This shows it by passed with a jumper I made to see if the cart would run. The micro was broke so I knew it didn't work.
Andy4639 is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes



All times are GMT -5. The time now is 10:24 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.