lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
 
Thread Tools Display Modes
Old 08-17-2012, 04:39 PM   #11
Not Yet Wild
 
Join Date: Aug 2012
Posts: 12
Default Re: 91 ezgo solenoid clicks, wont move

Removed resistor from solenoid as scottyb suggested and retested and the solenoid is good. you are correct on the microswitch and pot being in center next to solenoid. At least i think its the pot. It is a square box and it has two little wires that go to the controller. how do i test the pot?
amrstump is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Old 08-17-2012, 04:48 PM   #12
Gone Wild
 
camaroluvz28's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Florida
Posts: 839
Default

Bare with me I haven't tested one of these in a while I'm now a Yamaha dealer but I believe you take the black and white wires off the top of the controller and place your multimeter leads on them...while pressing slowly on the pedal ohms should rise from 0 to about 5k consistently not jumping all over the place...help me out fellas if I'm wrong on the wires I'm not at shop any more to look it up and 5 came quick so beers going down easy...
camaroluvz28 is offline   Reply With Quote
Old 08-17-2012, 05:25 PM   #13
Carts Unlimited
 
scottyb's Avatar
E-Z-GO
 
Join Date: Dec 2007
Location: So Cal
Posts: 51,002
Default Re: 91 ezgo solenoid clicks, wont move

I just posted this test in the Ezgo section on another thread.
scottyb is online now   Reply With Quote
Old 08-17-2012, 05:27 PM   #14
Gone Wild
 
camaroluvz28's Avatar
Yamaha
 
Join Date: Sep 2010
Location: Florida
Posts: 839
Default

Awesome so I was correct, things get a little hazy after 5 around my place!
camaroluvz28 is offline   Reply With Quote
Old 08-17-2012, 06:02 PM   #15
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 8,150
Default Re: 91 ezgo solenoid clicks, wont move

If solenoid activation circuit is working normally, but cart doesn't run, the problem is most likely in the High Current circuit.

Attach DVM test leads to B- and M- terminals on controller.
Press throttle pedal slightly, just until solenoid first clicks.
You should read full battery pack voltage, or very close to it.

If you don't:
Move the positive test lead from M- to the next connection in the series chain towards the controller side main terminal of the solenoid.
When you find B+, the problem is between where you found it and the previous test point.

If you do:
Press pedal slowly to floor.
Voltage should decrease to nearly zero as pedal is pushed.

If it doesn't:
Check throttle.

If throttle input to controller is good, the controller is probably bad.
JohnnieB is offline   Reply With Quote
Old 08-17-2012, 06:36 PM   #16
Not Yet Wild
 
Join Date: Aug 2012
Posts: 12
Default Re: 91 ezgo solenoid clicks, wont move

ok fnr switch good, solenoid good, potentiometer good, I just moved it back and fourth five times, ran normal. sixth time it wouldn't move. tested voltage on controller at m- and b- and had full voltage at first click and it did not decrease as i pressed the pedal. all large terminals on controller read full voltage when pedal is depressed wether in forward or reverse (except b- of course) new to this , is there someway i can test the controller? all cables are new and tight and batteries are fully charged.
amrstump is offline   Reply With Quote
Old 08-18-2012, 04:48 AM   #17
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 8,150
Default Re: 91 ezgo solenoid clicks, wont move

Quote:
Originally Posted by amrstump View Post
ok fnr switch good, solenoid good, potentiometer good, I just moved it back and fourth five times, ran normal. sixth time it wouldn't move. tested voltage on controller at m- and b- and had full voltage at first click and it did not decrease as i pressed the pedal. all large terminals on controller read full voltage when pedal is depressed wether in forward or reverse (except b- of course) new to this , is there someway i can test the controller? all cables are new and tight and batteries are fully charged.
You already are testing the controller. It is called the process of elimination.

If you have full pack voltage between B- and M- when solenoid first clicks, you've effectively eliminated everything except the controller.

If the voltage between B- and M- remains constant when pedal is pushed further, either the throttle isn't doing its job and telling the controller to pass current to motor or the controller is being told to pass current to the motor and isn't, or the controller isn't turned on.

If the throttle checks out good, the controller is either bad or isn't powered up. (Blue wire from MS-3 powers controller electronics)

The fact that the problem is intermittent, suggests there is an intermittent connection in the throttle circuit or in the Blue wire on third push-on terminal on top.
JohnnieB is offline   Reply With Quote
Old 08-18-2012, 08:46 AM   #18
Not Yet Wild
 
Join Date: Aug 2012
Posts: 12
Default Re: 91 ezgo solenoid clicks, wont move

tested the switches (2 on fnr and 1 in center) they test good. tested blue wire for voltage at controller 37 in forward, 37 in reverse, 0 in nuetral - so thats good. wiggled spade connector on controller for blue wire with pedal depressed and cart started working. took off connector cleaned spade with wire brush and crimped female a little tighter. CART IS WORKING NOW! I hope it keeps working and that intermittent connection was the problem. I will test it today and find out. Thank you JonnieB and everyone else for your help and patience with a new guy.
amrstump is offline   Reply With Quote
Old 08-18-2012, 09:15 AM   #19
Not Yet Wild
 
Join Date: Aug 2012
Posts: 12
Default Re: 91 ezgo solenoid clicks, wont move

Never mind it quit working again. tested voltage on blue wire at spade connector on controller and get 37v when pedal depressed, doesnt move. anything else I should do before I buy a new controller?
amrstump is offline   Reply With Quote
Old 08-18-2012, 09:36 AM   #20
Techno-Nerd
 
JohnnieB's Avatar
E-Z-GO
 
Join Date: Jun 2011
Location: West Virginia
Posts: 8,150
Default Re: 91 ezgo solenoid clicks, wont move

Personally, I would replace the blue wire in its entirety and at least replace the spade lugs on the wires to the pot box.

If that didn't cure the problem, I'd replace the controller with a aftermarket one.
JohnnieB is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
96 EZGO Fully charged, solenoid clicks will not move Electric EZGO
EZGO just clicks wont move Electric EZGO
92 club car clicks but wont move Electric Club Car
95Carryall just clicks,wont move Electric Club Car
solenoid clicks/ wont move Electric EZGO


All times are GMT -5. The time now is 10:52 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.