lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.



Post New Thread  Reply
Thread Tools Display Modes
Unread 08-05-2008, 05:03 PM   #1
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2008
Location: Kuntucky
Posts: 14
Default Is it the controller for sure ?

1999 EZGO DCS 36/volt with alltrax 400 controller

Below is what I have know or done but still wont go

Just replaced all batteries 3 days ago (Went down last night)
All conections are clean and tight getting a 38.7 v at the pack
Solenoid clicks when pedal pushed and reverse buzzer is working
Did the 7 step DCS troubleshooting sequence and all was well until pin 1&2
and it told me that i should see 14-15vdc and I got 0 on pin 2...it told that pin 1 that I should see .4 to 1.5 vdc and I got 10.4

Any Help ?
ukcats@att.net is offline   Reply With Quote
Alt Today
BGW

Golf car forum Sponsored Links

__________________
This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
   
Unread 08-05-2008, 05:22 PM   #2
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: Is it the controller for sure ?

Welcome to BGW

The 10.4 sounds like the ITS is fried. Had one a month ago measure the same thing. Replaced it and all is good.
roady89 is offline   Reply With Quote
Unread 08-05-2008, 05:40 PM   #3
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2008
Location: Kuntucky
Posts: 14
Default Re: Is it the controller for sure ?

Is there a way of testing this ?
ukcats@att.net is offline   Reply With Quote
Unread 08-05-2008, 06:21 PM   #4
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: Is it the controller for sure ?

If the ITS measure anything but .4 to 1.5 its not good. You said you measured it already and it was 10.4.
roady89 is offline   Reply With Quote
Unread 08-05-2008, 07:50 PM   #5
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2008
Location: Kuntucky
Posts: 14
Default Re: Is it the controller for sure ?

I went and double checked this thing and I am getting from the white wire at the 10 pin connector around 10.4V once the solenoid clicks and at a fully depressed pedal it goes down to 6.5

The Black wire I am getting 0 at the click of the solenoid and .02V at fully depressed.

Below is what is confusing... Are both the controller and ITS bad ?

This is straight out of the EZGO manual

Step

6)Pin 2 14 - 15 VDC - If not repalce controller I got 0 - .02
7)Pin 1 .4 - 1.5 VDC - If not replace ITS I got 10.4 - 6.5

Just seen this : The alltrax controller lights up green and stays on when the key is turned on but when the pedal is pushed down it will blink red 5 times until the pedal is relased then it goes back to solid green.
The Alltrax shows this as "Open Field.Check for open field wires"
ukcats@att.net is offline   Reply With Quote
Unread 08-05-2008, 08:25 PM   #6
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: Is it the controller for sure ?

Thats what it "Looks" like according to your test results. I would verify that its all hooked up properly before jumping to conclusions.

The field open, Run a continuity check on the feild circuit and make sure thats OK.
roady89 is offline   Reply With Quote
Unread 08-05-2008, 09:09 PM   #7
Not Yet Wild
E-Z-GO
 
Join Date: Aug 2008
Location: Kuntucky
Posts: 14
Default Re: Is it the controller for sure ?

Roady, I forgot to tell you that I am electrically challenged ....How to Run a continuity check on the feild circuit ?

Thanks for all of your help.
ukcats@att.net is offline   Reply With Quote
Unread 08-05-2008, 09:34 PM   #8
nimda
Club Car
 
Join Date: Jun 2007
Posts: 12,912
Default Re: Is it the controller for sure ?

You will need a volt ohm meter to check it with. Just probe the feild connections on the motor and then the cables going to the motor and you should have continuity....if not you have a problem and that explains the error code. Most volt/ohm meters will beep if you have continuity.
roady89 is offline   Reply With Quote
Unread 08-05-2008, 11:44 PM   #9
Golf Cart Photographer
 
rusty's Avatar
Club Car
 
Join Date: Jan 2007
Location: Wichita Falls Texas - My Ride 2010 Club Car
Posts: 6,238
Default Re: Is it the controller for sure ?

Welcome to the forum ukcats@att.net...................
rusty is offline   Reply With Quote
Reply
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO


Thread Tools
Display Modes


Similar Threads
Thread Forum
Controller help Extreme DC!
controller help Electric EZGO
need a controller Electric Club Car
New controller and pot box ?? Electric EZGO
First Log: New Controller Electric EZGO


All times are GMT -5. The time now is 03:59 PM.


Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.