lifted club cars - lifted ezgo
Home FAQDonate Who's Online
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO
Electric EZGO Electric EZ GO Marathon, Medalist, TXT and RXV.

Post New Thread  Reply
Thread Tools Display Modes
Unread 08-10-2008, 10:35 AM   #1
Getting Wild
gamer1's Avatar
Join Date: Oct 2007
Location: Hot Springs Village, Arkansas
Posts: 97
Default A slow pds problem with the rare posted FIX

2000 pds with speed chip.
I have read several threads about Pds carts having intermittent problems with slow speed or "no go" and have had this problem myself for over a year now. It seems like this is a problem with so many possible causes that not many I read about gets solved and you never hear about them again.The problem started with my cart again yesterday and wouldn't go away. Cart would start off like it was OK then never get any faster than a fast walk. Could not get a any beeps through the diagnostic mode. Ran through the trouble shooting guide with my tester and when I tested for voltage between # 5 pin in J1 and battery B- I noticed the #5 pin hole on the plastic connector was black. The slot on the controller was also black. The TS guide said replace the controller. I cleaned (best I could) both connections and cut a copper #14 wire about 3/16" and placed it in the #5 female pin with some ox-gard ( anti oxide electrical compound) and cart runs fine.
The main reason I post this is to show how important it is to pull and inspect ALL connections (as I have read in this forum over and over again). This could have (and still might) cost me a new controller and if the connector went un-noticed the new controller would not have solved the problem.
gamer1 is offline   Reply With Quote
Alt Today

Golf car forum Sponsored Links

This advertising will not be shown in this way to registered members.
Register your free account today and become a member on Buggies Gone Wild Golf Cart Forum
Unread 08-12-2008, 04:51 PM   #2
Not Yet Wild
Join Date: Aug 2008
Location: Texas
Posts: 25
Default Re: A slow pds problem with the rare posted FIX

Good post gamer1! I'm sure that others are the same as me, and like to hurt themselves jumping to eroneous conclusions.

Your methodical approach probably saved you and others, time and money.
Thanks for the post.
pappy42 is offline   Reply With Quote
Unread 08-12-2008, 07:38 PM   #3
The Last Moja Morani
shadowman's Avatar
Club Car
Join Date: Jan 2007
Location: jumping from cart to cart
Posts: 8,975
Default Re: A slow pds problem with the rare posted FIX

thats why i preach about service manuals for anyone who is going to work on their own cart and on an elec. even more important...........saves you so much time and guess work and saves you lots of money to boot...........the 1st time you have to use it that it paid for itself.........................
shadowman is offline   Reply With Quote
Go Back   Buggies Gone Wild Golf Cart Forum > Golf Cart Repair and Troubleshooting > Electric EZGO

Thread Tools
Display Modes

Similar Threads
Thread Forum
slow take off Electric EZGO
TXT is slow uphill Electric EZGO
Slow Down Electric EZGO
ezgo is very slow Gas EZGO

All times are GMT -5. The time now is 04:31 PM.

Club Car Electric | EZGO Electric | Lifted Golf Carts | Gas EZGO | Used Golf Carts and Parts

Powered by vBulletin® Version 3.8.6
Copyright ©2000 - 2016, Jelsoft Enterprises Ltd.
Content Relevant URLs by vBSEO ©2011, Crawlability, Inc.